Can't generate app because of invalid module path


#1

Hi all.

Pretty enthused to get started with JUCE. I encountered a problem very early, though: In trying to generate my first project, ProJucer complains, “At least one of your JUCE module paths is invalid! Please go to the Modules settings page and ensure each path points to the correct JUCE modules folder.”

Well, the modules path in that dialog is correct, and I can’t find any way to go to the Modules settings page because View/Show Modules Panel is greyed out under all circumstances.

Any insight would be welcome. This is under Mac OS (latest) and ProJucer 5.4.1.

UPDATE: OK, I found that the paths are set elsewhere, under the Projucer menu. The text in the dialog doesn’t appear to be correct; these paths are set on the Global Paths page under the application menu. Unless I’m missing something…

The other problem in this instance is that the location of the main JUCE folder was incorrect; it defaulted to ~, but there’s no selection control for it in this project-generation dialog. But you can select the location of the modules; wouldn’t it make more sense to select the JUCE location here, given that the Modules subdirectory typically resides under it?

Thanks!


#2

Did you look in the Global Paths dialog? You can access it from the Projucer menu.


#3

Thanks, 'za. I eventually did find it there; I updated my question with a couple more.


#4

Here the solution was to uncheck Use global module path (right below Modules Folder), so your project could use the Modules Folder that you selected.

But I totally agree with you, it is very confusing.


#5

Interesting; thanks for that info. So if “use global module path” is checked, the other one is ignored? If that’s true, it seems that the other one should be greyed out…