Introjucer Module Paths Wrong


#1

When trying to create a new project using the IntroJucer on Windows the module paths are incorrect and create a non-working project.

I set the modules path correctly when picking a project name to "C:\code\JUCE\modules" but once the project is created, every module is showing a path of "//?/C:/code/JUCE/modules". This incorrect path ends up in all the header files and the VS project doesn't compile.


#2

Do you mean you're setting the path in the global settings? (i.e. from the Tools menu)


#3

No, I don't even see an option for changing the modules path in Tools > Global Preferences > Paths.

After I click "GUI Project" from the <Create New Project> screen, I get taken to the screen where you set the project name/type/folder, target platforms, Files to Auto-Generate and Module Folders. The selection for Module Folders looks right as "C:\code\JUCE\modules". That is what I meant by setting the module path.

It is after that when I got to the modules list, it is showing all the module paths as "//?/C:/code/JUCE/modules" which is a bad path. I was expecting "..\JUCE\modules".


#4

Just spotted this myself, not sure why it's suddenly started doing this, will look into it. In the meantime, you can specify the JUCE module paths manually and remove the //?

Thanks for the bug report!


#5

Was this ever fixed? I am having this same issue. Both my Juce/User module paths are set globally as: ~/JUCE/modules

but every time I instantiate or download a new project, I have to manually set all the module paths again. They always instantiate to:
…/…/JUCE/modules

I’m still very new to JUCE so there could be something obvious I’m missing but this seem to be the same issue teriyaki had in 2015…


#6

I am not sure, but are you setting these?

or here?

Hope that helps


#7

Yes I set my global path:

I can’t actually say if your second question is true in this specific case because I am going through the tutorial series and all of the projects are already generated in projucer when I open them.


#8

All right, then the projucer is not involved at all.
Better open the .jucer file and hit “Open in IDE”. That way the project files are rewritten with your paths…
Hope that helps


#9

Hmm, that action was what originally notified me I needed to fix my module paths. xcode wouldn’t open until I manually rewrote all of the module paths to what I had written in the global search paths. I just tried to recreate the error message though and it’s not happening anymore. I also just downloaded some more tutorials to test and see if it would happen again and I can’t get the issue to occur. Not sure what I changed but it’s now working so thank you for the help!


#10

I just got the same issue again with a new tutorial I am doing ("looping audio using audio sample buffer"
After attempting to run in xcode via the projucer “open in IDE” command at the top, I got this error:

The Global Search Paths are exactly the same as before, and as soon as I manually change all of the individual modules to match my Global Search Path for modules (~/JUCE/modules), then the project opens/runs on xcode without errors


#11

That’s odd, in that case somebody of the juce team should have a look at it… it usually works for me…
Cheers


#12

You need to set the module paths in the tutorial projects to be correct for your environment before opening them. If you have your global paths set correctly in the Projucer then you can set all the modules paths to use this value by opening the module settings:


#13

Great this is what I was looking for. Thank you!