'CharacterFunctions' is not a class, namespace, or enumeration


#1

Hi!

I'm trying to cross-compile for an Arm (beaglebone) with VisualGDB under Visual Studio 2013 in Windows 8. When I compile for Windows, everything is fine.

But when I decide to use gnu++ and makefiles as suported from VisualGDB I get various error.

For example:

Fehler    23    error : 'CharacterFunctions' is not a class, namespace, or enumeration    D:\JUCE\modules\juce_core\text\juce_CharacterFunctions.h

I have told the makefile to include the path where "juce_CharacterFunctions.h" is located. But this doesn't change anything.

 

Some help would be appreciated!


#2

No Idea?

Any help would be very nice. Problem isn't solved until now..


#3

Hi there,

do you have any alternative to using Visual Studio, such as using cygwin or even a Linux virtual machine? It could be that the combination of gcc and Visual Studio messes up your build settings...

as far as I know Juce doesn't really support VisualGDB at the moment.


#4

Hmm thanks for the quick answer. I could try cygwin. I tried to compile it under Ubuntu, but I wasn't succesful in that. I spent hours over hours to install the right packages. I have to say, that I'm not a linux pro. But apart of that the project will have to be developed under Visual Studio. So I will have to solve this under the existing conditions.

VisualGDB was a very nice quickly installed solution with nice BeagleBone support. So. Can you give me a hint what could be tried further?

VisualGDB itself does nothing else to use an arm-optimised g++ compiler.

 

When I go to the "is not a class" error an right-click and then select "go to definition", VS finds the right file (juce_CharacterFunctions.h) and in

that the right definition ( class JUCE_API  CharacterFunctions{} ). So how do you think it can be that it says ( 'CharacterFunctions' is not a class).

Do you think think it's only because the compiler is not compatible? Or do you think I have to include any other files?

The project compiles for 90%. I think it is not much left to get it to work.


#5

Unfortunately I have no idea what went wrong in your specific project as I never used VisualGDB, and it's very difficult to tell without seeing the actual error messages in the actual project...

maybe some header files are not *actually* included during compilation even though they are part of the project? and/or maybe some include paths etc. are messed up?


#6

I got the project to compile succesfully on Code:Blocks under windows. So beause of any reason, Code:Blocks compiles

well, but VisualGDB doesn't (with the same Compilers). Both projects were created by the introducer. So I think I will

ask the VisualGDB developes...