[SOLVED]Can't compile Juce on Windows


#1

Hello everybody!

I Apologised if this question have been already asked, I searched but I didn't found the anwser.

I can't compile Juce on windows, I'm working on codeblock ( the team software...) but I having some erros in CharacterFunctions.h

"C:\Users\Simo\Desktop\IntroJucerTest\ReadMidi\Midi\Source\..\JuceLibraryCode\modules\juce_audio_basics\..\juce_core\text\juce_CharacterFunctions.h|353|error: 'ssize_t' was not declared in this scope|"

C:\Users\Simo\Desktop\IntroJucerTest\ReadMidi\Midi\Source\..\JuceLibraryCode\modules\juce_audio_basics\..\juce_core\text\juce_CharacterFunctions.h|354|error: 'maxBytes' was not declared in this scope|

Here my juce folder,

https://www.dropbox.com/s/ejx8nhga0sdpkxt/IntroJucerTest.zip?dl=0

I'm only trying to compile the juce main file generated by IntroJucer right now.

Thank you

Best regards

Goldiman


#2

Sounds like stupidness in whatever version of mingw you're using - ssize_t should be available in any decent C++ standard library.


#3

Hi

Thank you for answer, Sorry if the question sounds stupid but what version of mingw should I use? 

Thank you

Best regards!

Goldiman

 

Edit: I did what you suggested change compiler, I choose Microsoft Visual C++ 2010 but I have these issues

http://i.imgur.com/UTxyaZT.png

lnk2019 unresolved external symbol

What should I do ?

Thank you


#4

If you're using VC, please use the VC projects directly! If you try using codeblocks to build via the VC compiler, you're off-piste in terms of the kind of setup I've actually tested myself.


#5

Thank you ! I managed to make it work on visual studio 2013 :D

But I still having an issue the synthesisers of the demo, it doesn't produce any sound? Any idea why?

Thank you 

Best regards 

Goldiman


#6

Not enough info to answer that question. Could be a million different reasons why you're not hearing anything..


#7

Thank you for your answer.

I know this is vague... What Can I do to help you to understand my issue?

When I launch the demo app click on Synthesisers, I check my windows volume manager , put the volume at the maximum but I don't hear anything when i click on the piano keyboard and when I go to volume mixer I don't see the Juce Demo app.

Thank you

Best regards

 

 


#8

Hard to say - you could look at the audio device settings on that page of the demo app. Most likely you just have a strange device set-up and it's playing out of a channel that's not connected to anything.


#9

Nothing to say, except Thank you !

Work great

Have a nice day!

I will probably come back for a question later ^^ but this issue is solved !