Juce with new Mingw


#1

Hi forum, this is my first post and i have a question for jules (or anybody who wants to help me). AFAIK jules drop the support for MINGW in juce because this project (MINGW) use an older compiler (GCC 3.x). Thats ok, but exist a veri nice distribution of MINGW with the latest version of GCC (4.4 i think) called Mingw-TDM. I use this dist for a long time ago and it is quite estable. My qustion is, ¿Do you think re-support Mingw for Juce?. If you use GCC to compile juce under linux, then you can use MINGW-TDM to compile Juce under Windows. Im on it in this very moment, but fails to comply becase (i think) Juce don’t consider in any way use gcc under windows.

I know that always can use VC++, but i dont want use that, mostly because a dont know how.

thx in advance.


#2

i was succesfully compiled Juce with Mingw-TDM. Just i added the inclusion of stdio.h to juce_StandardHeader.h and all runs like a charm.

The exe genenerated is huge compared to the original jucedemo.exe, so any suggestions to minimize de size of this file are welcome.

I have another small question, Why when i build the demo with Juce amalgamated aproach is still necesseray link the object code with the static library build of juce?

thx in advace.

EDIT: i use de 1.46 version of juce.


#3

I agree to that, the library compiled like a charm. But when i tried to build the demo project, everything behaved like if i didn’t link against the necessary libraries. But the libraries have been set, the search directiories too, and it doesn’t help. Just undefined reference everywhere. Any help, pls? :slight_smile:

(I used the project file came with juce, and set the lib search dir to mingw/lib in the global settings. And the compiler doesn’t find any of the libraries. Even the libjuce.a/libjucedebug.a! I checked, it is there, the compiler should see it… Also tried to delete all the libraries, and then add to the project again, but with absolute path. Nothing happened… Oh, and i use code::blocks :D)