CodeBlocks and JUCE - Will Not Compile


#1

Hello world! I have a very frustrating problem I’ve been messing with for some hours. I’m sure it’s an easy fix for you guys so I was hoping someone could provide me a solution.

When I attempt to compile anything that uses the JUCE library, I get the following error :

========================================================
C:\JUCE\Solar4\JuceLibraryCode\juce_audio_basics.cpp|9|fatal error: juce_audio_basics/juce_audio_basics.cpp: No such file or directory|

I have no idea why the compiler can’t find the directory considering that it exists. Here’s the filepath in Windows explorer

C:\JUCE\Solar4\JuceLibraryCode

How can I get the compiler to load this file? Thanks!


#2

Are you using the develop branch of JUCE? We’ve recently fixed a few things in the Code::Blocks exporter.

You’ll need to recompile the Projucer and resave your project after switching branches.


#3

Thanks for your reply. So are you suggesting I should use the develop branch, or the master branch? Because I’m currently using the “master” one.

EDIT : I just tried downloading the develop branch on github and it didn’t have the projucer.exe file within. What am I supposed to do?


#4

Oh, sorry - I was suggesting that you use the develop branch. All of our recent work goes onto the develop branch, which is then periodically merged into the master branch. The Code::Blocks fixes are new enough that they haven’t made it to the develop branch yet.

The Projucer executable is only distributed in direct downloads. When you clone from github you’ll need to compile the Projucer manually. On Windows the way to do this is to open extras/Projucer/Builds/VisualStudio2015/Projucer.sln in Visual Studio 2015 and build the solution. Visual Studio Community is free and the recommended way of creating JUCE apps on Windows. We rely on the forum to report Code::Blocks exporter errors but Visual Studio is internally tested.


#5

Alright! I tried it out with Visual Studio, and I no longer have the same problems I did with Code Blocks! Thanks for your suggestions.


#6

Did this ever get fixed? I just built ProJucer from latest develop and I’m having the same issue on Ubuntu 14.04

/home/rrabien/dev/JuceLibraryCode/juce_audio_basics.cpp|9|fatal error: juce_audio_basics/juce_audio_basics.cpp: No such file or directory|

#7

Yes, this was fixed.

Are the paths to your modules correct?


#8

Ah, that was it thanks.

Feature request for ProJucer: When you create a new export target, it copies the modules location from an existing export target.