JUCE newbie need help to get it to work (please?)


#1

Hi everyone!
I’m trying to set up JUCE with CODE::BLOCKS, but nothing seems to be working.

I have followed the guide in the C:/JUCE/docs/JUCE readme.html readme.
1.open the Juce project: juce/build/win32/codeblocks/juce.cbp

  • CHECK!
    2.open the demo app project: juce/extras/juce demo/build/win32_codeblocks/JuceDemo.cbp
    -CHECK!
    3.Build first the “Juce Library” project, and then the “Juce Demo App” project. If your build environment is set up correctly, these should just work and the demo app should run.
  • ERROR.

I’m using JUCE v. 1_50 (I guess) from http://sourceforge.net/projects/juce/files/ (the link on the main page). I’ve placed it in C:\JUCE . I’m using CODE::BLOCKS 8.02 and I’m running Windows XP SP2.

I open c:\juce\build\win32\codeblocks\juce.cbp and c:\juce\extras\juce demo\build\win32_codeblocks\JuceDemo.cbp in codeblocks.

I then build first the juce.cbp projekt (getting 0 errors and 96 warnings) and then the JuceDemo.cbp projekt (getting 1 error and 1 warning) with the error being: C:\CodeBlocks\MinGW\bin\ld.exe: cannot find -ljucedebug .
And thats where I’m stuck. I’m guessing I have missed something somewhere, or have some wrong settings or something, but I have no idea where to go from here, so any and all help is very much appreciated.

Btw. I’m using the GNU GCC Compiler in codeblocks.
Also, sorry if I placed this in the wrong topic.

  • Steffen

#2

It looks like lots of people are having problem with codeblock. Please check this thread, it might help you.
http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?p=19473


#3

the linker can’t find the library, either it’s not there, the paths CodeBLocks project properties are not set properly (they need to be set so that the .lib file created by the juce build is found).

i work with codeblocks on linux, juce works like it should. though if you are on windows i recommend (and i guess anyone here will tell you the same) to use VS express (it’s free) or some form of VS, you’ll get much better results much faster. Codeblocks is old not updated and mingw gcc is even worse.


#4

Unfortunatly there doesn’t seem to be a solution in that tread either.
If anyone have it working with codeblocks, please share your info with the rest of us :slight_smile:


#5

I have never used codeblock. Working on windows Visual studio is the best option. Visual express is free, you can give it a try.


#6

I tried using juce 1.46 and apperently that worked as it should, so will be using that instead :slight_smile:


#7

youll end up with loads of gotchas and bugz that jules fixed. 1.46 is very old.


#8

That confuse me. How does juce 1.46 work but juce 1.50 doesn’t ??? :?:

atom is right, you had better use the latest version of juce. It’s not just the bugs but also new features.