CodeSign fails suddenly

I’ve been working on a plugin project and I usually work in the standalone app as I’m developing. Yesterday, everything was just fine. This morning, same project, nothing has changed, but it’s now failing code sign.

/Users/me/projects/MyThing/Builds/MacOSX/build/Debug/MyThing.app: code object is not signed at all

In subcomponent: /Users/me/projects/MyThing/Builds/MacOSX/build/Debug/MyThing.app/Contents/MacOS/MyThing.ld_mSGwzw

Command CodeSign failed with a nonzero exit code

I checked the Signing settings and everything looks good, Automatically manage signing is set, I see my Team and Development Certificate all there, not expired.

Xcode 13, Big Sur 11.6

Any ideas?

Have you tried doing so manually - and if so, what was the end result?

And though I’m not aware of your specific development situation, it’s possible your certificate expired so it’s worthwhile checking that out.

I tried manually, same result.

After some googling on random sites, I added --deep to Build Settings/Signing/Other Flags and that fixed it.

Odd.