iOS signing fail

Hello,

I’m trying to create a basic “hello world” for an iPad using a real iMac. I setup the Projucer for iOS exporter (Application->Audio), then I fill in the Development Team ID with the key, save the project, and I run it in my iPad. It works, great.

However, I do some light modifications, I change the UI colour, the text, and maybe I add a small noise in the background. Then I click on the play button again to run it in my real iPad and now it fails!!! Why does it fails after these light modification?

This is the error report:

Showing Recent Messages
CodeSign build/Debug/Lola6.app
cd /Users/lolajuezsarmientoramos/Desktop/Lola/Lola6/Builds/iOS
export CODESIGN_ALLOCATE=/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/codesign_allocate
export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"

Signing Identity: “Apple Development: XXXXXXXX@gmail.com (4NJZN6KH38)”
Provisioning Profile: “iOS Team Provisioning Profile: com.yourcompany.Lola6”
(ed6bb32b-1426-4e7e-a2ff-138df0723c8c)

/usr/bin/codesign --force --sign E2C67E574F095BC26E2CFA7381087547360A6FDE --entitlements /Users/XXXXXXXXXXXXXXXXXXX/Library/Developer/Xcode/DerivedData/Lola6-ayzrrbanshupzwgxmfeyryzufnwu/Build/Intermediates.noindex/Lola6.build/Debug-iphoneos/Lola6\ -\ App.build/Lola6.app.xcent --timestamp=none /Users/XXXXXXXXXXXXXXXXX/Desktop/Lola/Lola6/Builds/iOS/build/Debug/Lola6.app

/Users/XXXXXXXXXXXXXXXX/Desktop/Lola/Lola6/Builds/iOS/build/Debug/Lola6.app: resource fork, Finder information, or similar detritus not allowed
Command /usr/bin/codesign failed with exit code 1

I get this. Its usually caused by icloud tagging files. I use this pice of software before doing a clean and build and it should work fine: ‎CleanDetritus on the Mac App Store

I tried it, I had no idea what I was doing, but anyhow, the problem was solved, thanks