Debug build doesn't generate Debug Info


#1

I have a Introjucer project. It works perfectly to create all those nice project files :slight_smile: Unfortunately, I have a small problem with the Debug mode.
When I recreate the project files for Visual 2008 the newly generated vcprj doesn’t include “/DEBUG” nor “/MAP” nor “/MAPINFO:EXPORTS”. So it’s quite impossible for the vc debugger to step debug into the generated binary. Ok, it’ not a big deal since I can enable them each time I need 'em. Well since I am still in the phase of designing the application new files are added frequently and I run Introjucer quite often. Each time a new file is added I have to reenable the Debugging this is quite annoying :roll:
It there a possibility to generally enable it for the Debugmode?

Thanks.


#2

you should be able to debug every new generated project by default (just start in debug build from your ide), there is no need to edit the configuration


#3

Hey chkn,

thanks for your reply.
Well, I don’t have the possibility to start the debug build from the IDE since I am building a DLL.
Furthermore I am quite sure not all possibilities to debug are enabled when neither “/DEBUG” nor “/MAP” nor “/MAPINFO:EXPORTS” are enabled.
IMO a VST is also a DLL that needs to be debugged some times :wink: How about that? Is it working without any changes to the project preferences?

regards


#4

Of course you have! Define the executable which is using the dll in : Configuration Properties -> Debugging -> Command


#5

Thank you for the answer.
Hhm, of course I know that I can attach an executable there :wink: Well, this is not suitable for me since I have to use another IDE that starts the main program. :mrgreen:
Probably this is again a very uncommon way of developing with juce … I’ll need to live with changing the properties over and over again … or when I’ll provide a patch for the debug mode. I am sure those switches won’t destroy anything else.