ERROR: Deployment target setting doesn't work after updating Xcode to version 8.0: <computer> cannot run <application>


#1

Hi,

after updating Xcode to version 8.0 this morning I got the following error:

  <name of my computer> cannot run <name of application>.

  <name of my computer> runs macOS 10.11.6,
  which is lower than FFT’s minimum deployment target.
  Change your project’s minimum deployment target
  or upgrade pippa’s version of macOS.

I had to change the ‘Deployment Target’ to 10.7 (or higher) to fix the problem.


How to change the deployment target

Manually using Xcode:

  • open the project navigator (click the leftmost icon in the upper line of the leftmost pane)
  • open the ‘General’ tab
  • go to the ‘Deployment Info’ section
  • Change the ‘Deployment Target’ to 10.7 (or higher)
  • recompile

By editing the project settings:

  • open the corresponding project settings in file
    <project dir>/Builds/MacOSX/<project name>.xcodeproj/project.pbxproj
  • change   MACOSX_DEPLOYMENT_TARGET_ppc = 10.4;
    to       MACOSX_DEPLOYMENT_TARGET = 10.7;
    (or some higher value)
  • recompile

I hope this helps. Thanks,

Dietrich


#2

We’ve just released an update to JUCE on master/develop. In this update, if you do not specify any deployment target, then JUCE will automatically choose the newest deployment target which works well with JUCE. This will usually be the newest OS/iOS except when (like now) the next OS is still in beta or golden master.


#3

Hi Fabian,

Thank you!

Compilation works again without need to manipulate the deployment target :slight_smile:

Cheers, Dietrich