Please set MACOSX_DEPLOYMENT_TARGET to default


#1

In all the projects, MACOSX_DEPLOYMENT_TARGET is defined to 10.9.

On earlier OSs it's a bit annoying to have to change that everytime to get a successfull build.

Could you revert that to the default? (at least for the debug level)


#2

The reason it's not set to default is because if you're building on 10.10 with the latest Xcode, the default setting prevents it running on systems earlier than 10.11 (!) Bit of a stupid behaviour by Apple there, so we set it to 10.9 assuming that almost no developers would still be using older systems, and even if they were, this is only demo code.


#3

fair enough :)