Example Builds not working - MAC


#1

Noob question.
I installed Juce today. I followed the instructions and put JUCE folder in my user home folder. I can set up a new project fine. I can open all the example files (e.g. Demo) in JUCE/Examples/ and build & run these fine.

However if I download one of the example zip files from the tutorials on the website (e.g. : tutorial_simple_synth_noise.zip) and move that unzipped folder alongside the example folders (or other places I’ve tried) then when I open that file, I’m getting build errors.
Firstly the core modules can’t be found, so on the Config tab I right click on the modules and set the location to …/JUCE/Modules - but then I get lots of errors on the build tab such as …/juce_audio_basics.h file not found.

What am I doing wrong please. Many thanks,


#2

Hi Domc,

It’s easier to place a directory containing the unzipped tutorial projects in a location where they will find JUCE without your having to change things in the Projcuer projects.

  • First, you might need to rename your JUCE directory to juce on a case-sensitive OS.
  • Then create a juce-tutorials directory* in the same directory that contains your juce directory.
  • Unzip the tutorial projects (within their own sub-directories) into the juce-tutorials directory.

[*] (Or whatever you want to call it - the name of this is not important.)

Like this:

Best,
Martin


#3

Thanks for helping Martin - but I’ve tried and still getting the same type of errors.

I changed the JUCE directory to juce. I set up a juice-tutorials parallel. And then I doubled clicked on the jucer file (or opened from the file menu) both times I get the errors hopefully shown below.

Errors.

Thanks for any help


#4

Just be sure, is the modules directory in juce? You don’t, for example, have something like juce/juce/modules

And was that a fresh copy of the tutorial zip? Or the one you modified before?

That set-up really should work without any changes.


#5

Hi Martin,

The modules directory is in just a straight juce directory as you can see below.

I deleted the previous tutorial - downloaded a new one - and unzipped in the juce-tutorials folder.

When I open it, the modules at least seem to be found - i.e. previously I’d get an error looking at
this page saying that juice_audio_basics couldn’t be found.

However when I go onto build and press the compile button I get

I haven’t altered any of the files - just double clicked on the jucer one to open, and then pressed the compile button.

Thanks for your help


#6

That’s a bit baffling. Can you do Save Project and Open in IDE… in the Config tab to open the project in Xcode? That should give more detailed errors on what’s going wrong.


#7

Baffling indeed! And it gets stranger - when I run in the IDE it works fine (or I get a window come up producing white noise and nothing else which I presume is fine).
I do get a warning error below - which looks pretty technical.
So if I build in the IDE i’m fine - but if I build in the projucer I get the errors from yesterday!!?

Anyway thanks for your help as at least I can do some of the tutorials now.