Font size changes between Windows and macOS

Was there something changed in the font rendering between 5.4.3 and 5.4.4? Embedded fonts are rendering about 15% larger in size, and somewhat “bolder” on macOS and iOS than they are on Windows now. I’ve tried multiple fonts, both OTF and TTF, and this seems to be consistent.

macOS / iOS:

image

Windows 10:

image

This particular example is Abel Regular, freely available from Google Fonts.

I’m not sure why the size would be different, but you can select JUCE_DISABLE_COREGRAPHICS_FONT_SMOOTHING in the options for the juce_graphics module.

You guys need to work on the verbage for that particular setting. :slight_smile:

Having said that, no difference between the two.

Just for fun, I tried turning off DirectWrite on Win, no change there either.

We made some changes to move away from a deprecated API:

If you go back to the commit before that do the fonts return to their expected size?

Actually, found it. It was a combination of two bits of stupidity:

  1. I had built a VST3 during testing earlier in the week, and was not building it during this morning’s confusion, but I was looking at it. Since all the fonts I use are fairly similar (slightly rounded sans serif semi-condensed) I just didn’t notice that I wasn’t looking at a new build every time.

  2. The exact font was actually the problem. It is Barlow, available from Google. It renders very differently on Mac and Windows.

Long story short: nothing to see here. My mistake. I just did an actual build with actual Abel that is actually correct, and it is functionally identical on all three platforms.

1 Like

Very nice looking GUI design btw!

1 Like