Funky Looking App Icon

Hi All,

So my application icon is meant to look like this…
CodettaLogo
However, comes out looking like this…
18

Its size is 128x128px and I’ve loaded it in the “Icon (Large)” section of the Xcode exporter settings. So what have I missed?

UPDATE: This also happens when trying to use the JUCE Icon itself.

Thanks in advance,
Corey!

Looks like you did an FFT on it :slight_smile:

(sorry, no idea really what happens)

2 Likes

Have you try to make a 512 X 512 PNG file like the Juce Icon ?

Nope, but I will try right now…

Unfortunately not, and the same behaviour occurs when loading in the JUCE Icon itself.

I‘ve seen such artifacts before - when creating a JPG with FFMPEG, and viewing it with macOS‘s Preview Application. I assume that your OS incorrectly interprets the file format - what’s your toolchain for creating this icon file?

1 Like

Well I do it with success like you can see in these captures. Maybe crash your Xcode exporter and do it again ???
(My icon is a PNG 512 in 72 dpi and in the binary)

34 06

1 Like

I’m loading it into GIMP and then overwriting the PNG once I’m done with tweaking.

Solved! I deleted the build for the XCode project, reran and it was fine.

Thanks!

1 Like

Have you Try with a blank project ?

Envoyé de mon iPhone

Nice happy for you.

Envoyé de mon iPhone

1 Like

I have this issue for over a year now and still have no solution. I tried all the suggestions above. Anybody else seen this ?

Importing SVG files does not work, use PNG images instead.

I don’t use SVG for icons. They are plain PNGs

I’m seeing the exact same thing (latest master branch, XCode 11.13.1).
When I do Get info on the app, it does show my icon in the preview section, but the icon at the top left is the scrambled one.
@fordc004 What do you mean with “I deleted the build for the XCode project, reran”? Do you mean: deleting the exporter for Mac in the Projucer and then re-creating it?

If I open the XCode project, select my application target under “TARGETS”, go to General --> App Icons and click the “Use asset catalog” button there, after the migration, I end up with a Source parameter with the value “Appicon”. When I build now, the app has the correct icon.

I also noticed this in Apple’s docs: “Don’t provide app icons in ICNS or JPEG format.** Add de-interlaced PNG files in the app icon fields of your Xcode project’s asset catalog.” The icon files I selected in the Projucer (small and large) are PNG files in my case (a bit small though: 72x72 and 144x144), so maybe something changed in XCode or the Projucer when it generates the necessary files for the app icon? And then when I click that button in XCode it does its own thing to set up the icons in the right way?

If I now look in the bundle, I see Icon.icns (which was there before I clicked that button) and also Appicon.icns (which was not there before). And the Info.plist now has 2 entries:

<key>CFBundleIconFile</key>
<string>AppIcon</string>
<key>CFBundleIconName</key>
<string>AppIcon</string>

Before (with the unmodified Projucer-generated XCode project) I had only this in the Info.plist:

<key>CFBundleIconFile</key>
<string>Icon.icns</string>

This is of course not a viable solution though.

If you look in the project file where you will find the projucer file and the source file, there is a folder called builds. Deleting this (which contains xcode projects and a few other bits and pieces) often solves odd build errors like this as it will force the projucer to regenerate the whole thing.

@DavidCNAntonia is spot on. I deleted the build folder, not the exporter in the projucer.

Ah yes, I had already tried deleting the Builds folder: that didn’t help for me, still the strange icon…

@wkundrus Did you ever find a way to solve this? Seems like the things mentioned above didn’t work for you either.

My solution was fixing it when the installer is build, much later. I have a sane icon file, not generated by Projucer that I copy into the binary, before code signing and notarisation.