GCC 4.6 fix required

In the makefile that’s Jucer generated, you need to move -ljuce (or -ljucedebug) first in the link command, else you’ll get linker time DSO weak symbol errors.
It doesn’t make any change with previous compiler, so you can probably apply that fix general into the IntroJucer’s export code

In Juce’s modules tree, the -lXext disappear from the libraries. Is there any reason for that ?

Was it ever there? I’ve been happily compiling without it for years…

You need it since XShm got moved to the X extension library (I don’t know if it’s recent, it seems that I fixed the Makefile of a two year ago project for this).
You probably haven’t experienced this if you don’t enable that specific options in the juce config.
Ideally you should enable it only when XShm is selected, but it doesn’t hurt to make it on always.

Ok, thanks, I’ll add it to the default libraries.