How to Resolve juce_checksettingdefinemacro.h Errors

Hi, I’m No.0.
(I’m Japanese, so I can’t write well, sry :frowning: )
(I’m a beginner in programming)
So, at my school, we have something like an extended version of a free study project. After considering various research topics, I ended up deciding to create my own DAW.
For the time being, the template is GUI, I tried adding all the modules that can be added, selected VS2022, opened sln and tried to build without touching any code.
Then I get an error like the image and the build does not succeed.

After some digging I found the following links:

However, the problem could not be solved this way, probably because the version of Projucer has changed.
Checking the settings in the same location does not find such an item.
I couldn’t find AppConfig.h from Solution Explorer, and I didn’t understand it even after reading the tutorial.
How can I solve this?
Sorry for making you go to all this trouble…

(2023/07/23 9:40 added) Notice and apology for multi-posting in this question

I have posted similar content to this question on several other programming question bulletin board sites.
It wasn’t an urgent matter, but I was worried about the narrowness of the neighborhood and tried to expect it to be seen by an expert as much as possible, resulting in a violation like this time.
Other sites with similar posts:
・teratail (【JUCEでDAW自作】とりあえずビルドを成功させたいだけなんです...)
・ Qiita ([Q&A] 【JUCEでDAW自作】とりあえずビルドを成功させたいだけなんです... - Qiita)
・stackoverflow (c++ - 【JUCEでDAW自作】とりあえずビルドを成功させたいだけなんです - スタック・オーバーフロー)
I am very sorry that I unknowingly violated the contents of the help this time.
For myself, for the first time this time, I fully recognized the concept of “multi-posting” and that it was a violation of manners (although I may have seen it before).
There were various documents that criticized multi-posting, but I couldn’t say anything because the contents were convincing. (Sorry for saying so much)
From now on, I will try to post content that does not look like multi-posting as much as possible, and post questions while being aware of the effectiveness of searches and the significance of information accumulation.
Once again, we sincerely apologize for the inconvenience caused.

solved! Sorry for the inconvenience.

It looks like an image,
Select “modules” from the Projucer project setting screen
→ Remove the module “juce_audio_plugin_client” from the project (the image has been removed; there is no such module anymore)
→ Re-open Visual Studio
→ Build with Shift + Ctrl + B as usual,
→ Build succeeded!
I don’t know if it’s okay to remove it, but that’s the solution for building.