Problems Compiling JuceDemoAU - Rez SysError 0


#1

Hi!
I´ve downloaded and compiled the Juce Library for OSX today, and all worked fine.
I even managed to compile the JuceDemo App with the fix/hack I found here:
http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?t=3014&postdays=0&postorder=asc&start=45

However, now I´m trying to compile the JuceDemoAU (since 3 hours), but I always get the same error after linking:

I´ve searched the forum and the internet up and down, I tried adjusting the include paths of my project, copying the .h file around, and even hacking the juce_AudioUnitWrapper for the correct path, all to no avail.

Can anyone please help me with this?

OSX 10.4.11, Juce 1_46

Cheers,
Christian


#2

Never seen that one before. Maybe try the SVN tip instead of the 1.46 code…


#3

I think I remember seeing a similar (possibly the same) error when I tested a Developer tools install in somewhere other than /Developer

I had the same problem with non-Juce AU stuff so I suspect the problem was in the Apple AU example code. I never fixed the problem except by going back to using /Developer !

Are you using Xcode from /Developer/Applications or is it installed in a different path?


#4

hi jules,
thanks for your quick reply!
I checked out the svn trunk and tried compiling.
the lib works fine, so does the app, but for the plugins now the “CommonReleaseSettings.xcconfig” and “CommonDebugSettings.xcconfig” are missing. I´ve also searched the forum and svn repository but couldn´t find anything.

Could you please help me with this?

Cheers,
Christian


#5

hi martinrobinson,
thank you too for your quick answer!
my Xcode path is /Developer/Applications though, so that shouldn´t be the problem…


#6

hmmmm…
it works if I copy all the content of JucePluginCharacteristics.h and paste it instead of the #include “JucePluginCharacteristics.h” in juce_AudioUnitWrapper.r

Really strange…

Also tried adding Rez paths like crazy in Project and Target Build settings.

Maybe somethings wrong with my Rez?
Downloading Dev Tools now to reinstall…


#7

Don’t think reinstalling will make any difference - it’s clearly just your rez path that’s not letting it find that file…


#8

so where else can I check for Rez settings?
I checked the Project and the Target build settings.

Is there another place to configure Rez?

It should be enough to have the path of JucePluginCharacteristics.h in “Rez search paths”, right?

Also in the Rez call there is still an include for a 10.5 SDK directory which I couldn´t find anywhere in the build settings (like so: -i /Developer/SDKs/MacOSX10.5.sdk/usr/include). I´m on 10.4, which is also included.
What happens if Rez includes a path that isn´t there?


#9

That’s all I’ve ever done. Maybe just a typo in your path or something simple like that?


#10

I can’t seem to get this one to work either. I played with putting the path for the JucePluginCharacteristics.h file everywhere in the Build Settings; Header Search Path, User Search Paths, Rez Search Paths, etc. and still can’t get it to compile.
Can anybody else relate to this problem and how did they fix it?


#11

I figured it out. Can’t have your project in the /Developer directory, which doesn’t really make any sense. Oh well…


[Solved] AppConfig.h Rez Error 3 - AU, JUCE 4.2.4, macOS Sierra, XCode8