[Solved] AppConfig.h Rez Error 3 - AU, JUCE 4.2.4, macOS Sierra, XCode8


#1

Hey there,

I finally found the time to look into JUCE 4, downloaded the 4.2.4 and installed it on a fresh (JUCE/XCode wise) system.

Opened the plugin demo project and tried to compile it, which works fine for everything (VST2, VST3, AU3) except for AU plugins. When I select to not build an AU from the project, everything compiles OK. When I select to build an AU from the project, XCode constantly spits Rez error #3 at me.

The trouble seems to be that it can’t find the AppConfig.h file.

Please believe me, I did search all across this board and Google, I found threads from many years back with similar issues. Some old threads here pointed to rawmaterialsoftware.com but that domain seems to have disappeared. Anyway, I jumped through all the hoops the best I (not a veteran Xcode developer) could, attempted all the fixes I could find and think of, these are the ones I remember:

  • Install AudioUnits SDK. I put it in /Developer/Extras, /Applications/XCode/Contents/Developer/Extras/ etc. and all over the place, with and without SymLinks. I know that JUCE 4 comes with the AU SDK, but I wanted to be extra sure.

  • Confirm that AudioUnits.framework is in “Linked Frameworks and Libraries”

  • Check that the file actually exists (it does)

  • Install and select older OSX SDKs (inside the XCode.app/) and use an older base SDK, select another target platform. Tried with all the SDKs I have installed (10.7-10.12)

  • Use different Rez flags

  • Select Data Fork

  • Define folder containing AppConfig.h in ProJucer debug/release build options (“header search paths”, “Custom Xcode Resource Folders”)

  • Define folder containing AppConfig.h in XCode all over the place (Rez search paths, header search paths, user header search paths, …)

  • Included AppConfig.h even in Introjucer project so that it shows up in XCode in the JuceDemoPlugin source folder.

But nothing works, all builds constantly fail with Rez error 3.
Can anyone tell me what I’m doing wrong?

This is the error message it spits out:

/Developer/SDKs/JUCE4/modules/juce_audio_plugin_client/juce_audio_plugin_client_AU.r:35: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - SysError 0 during open of "AppConfig.h".
Fatal Error!
/Developer/SDKs/JUCE4/modules/juce_audio_plugin_client/juce_audio_plugin_client_AU.r:35: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Fatal Error, can't recover.
AppConfig.h: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Since errors occurred, /Users/rob/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-fhjyipguranlcndoakkzkqdngvls/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin (AU).build/ResourceManagerResources/Objects/juce_audio_plugin_client_AU.rsrc's resource fork was not written.
Command /Applications/Xcode.app/Contents/Developer/usr/bin/Rez failed with exit code 3

SOLUTION:
Move the project directory outside of the /Developer/ folder.


#2

I got this from time to time, it did go away for me by:

  • Rebuilding the Projucer and run that one, sometimes when I double-click a jucer file, it opens an old one…
  • Open the jucer file
  • Click “Save and open in IDE”
  • Rebuild (eventually do a clean first Cmd+Shift+K)

The reason might be, that the kind of how the projucer writes the project and how stuff in the modules is arranged gets out of sync, so using the same modues that the projucer used could help.

Good luck


#3

Thanks for your reply.

I tried rebuilding the Projucer, didn’t help. This also happened when creating a new blank plugin project, open in IDE, Cmd+B, Rez error 3.

In my previous build attempts I’ve constantly used the Cmd+Shift+K ‘clean’ action, because I sometimes got “can’t remove directory, not empty” errors when I was playing around with the include paths. Also didn’t work, so any faulty remainders are also not the underlying issue.

:confused:


#4

I’m afraid I can’t reproduce this. I have, however, seen it before - but this was years ago when I first started using JUCE and I can’t remember how I sorted it out…

Perhaps someone who encountered this more recently could let us know.


#5

I did not have JUCE installed and working on those machines before, so nothing ongoing was broken; but now I can’t even get started. :slight_smile:

I could reproduce this on two entirely unrelated and independent machines. One is my Mac Pro at home, the other is my Mac Mini at work (just to try it out). Updated to macOS Sierra, updated to XCode 8, installed JUCE 4.2.4, loaded audio plugin demo in Projucer, opened in IDE, Cmd+B … Rez Error 3. Same with any new plugin project I create from within Projucer, either the delivered one or any self-compiled version.

My MacBook at home is still on El Capitan, no XCode or JUCE on that yet, I guess I’ll give it a try tonight. Is there any debug info I can collect during such a failed build and pass on to you that would help?


#6

A bit of forum digging unearthed this:

Does moving the project out of /Developer help?


#7

Yes, that did it, wow!
AU builds work fine now when I put projects in a place like ~/Documents/Projects/.
Thank you so much! :heart:

I like to keep my stuff in one place, rather than fragmented across the drive in 100s of unconnected folders, so having my projects in a place like /Developer/Projects/ seemed a sensible choice for me. And as far as VST2/3 goes, this didn’t seem to be a problem.

Is there anything one can do to fix this? Or is it “projects outside of /Developer dir” forever?


#8

Maybe think of it as “keep your projects inside your user folder” rather than worrying about where not to put them. It’s considered very bad practice on unixes to use global system folders as working areas!