Xcode 4.1 & JuceDemoPlugin Compilation errors


#1

Trying to compile the demo project in Xcode 4.1, I got these errors.

any tips for me?


#2

wow!
I tried to replace MIDIEvent word by AUMIDIBase::MIDIEvent etc.
BIG error of compilation.
After that, I removed the AUMIDIBase::
Retest and …
Not the same error
WOW
strange

check that.


#3

tried this

no success :?


#4

http://www.rawmaterialsoftware.com/viewtopic.php?f=4&t=7752


#5

it is very strange (and probably only because of XCode 4.1)
I tested that yesterday. It didn’t work.
Now, I remade the XCode project file with introjucer.
Opened it in XCode 4.1
Some warning
Build
NO PROBLEM.

Indeed, the bundle is built etc.
BUT still not “detected” by my system (I mean by auval -a or even -v with specific arguments)

Jules, I know it isn’t a juce pb.
trying to dig that


#6

I just figured out something… it builds the .vst & the .components at the same time.

I mean, when I launch the build task, it works… it works… and in the Product folder, there was only the .component
but indeed, it creates the .vst too, in the ~/Library/Audio/Plug-Ins/VST folder

This one works fine in Ableton Live & other DAW I have and tested with.

But how to make that AU working ?!


#7

If the AU isn’t found it means that something’s wrong with your resources file or plist, maybe the info in there isn’t correct in some way? I think there are probably a bunch of threads on this subject if you do some searching.


#8

really searching hardly.
but you pointed me to one special thing about the plist & ress files.

posting my solution as soon as possible !


#9

my plist in the bundle is

[code]<?xml version="1.0" encoding="UTF-8"?>

BuildMachineOSBuild 11B26 CFBundleExecutable JuceDemoPlugin CFBundleIdentifier com.rawmaterialsoftware.JuceDemoPlugin CFBundleName JuceDemoPlugin CFBundlePackageType TDMw CFBundleShortVersionString 1.0.0 CFBundleSignature PTul CFBundleVersion 1.0.0 DTCompiler DTPlatformBuild 4B110 DTPlatformVersion GM DTSDKBuild 11B26 DTSDKName DTXcode 0410 DTXcodeBuild 4B110 [/code]

sounds correct afaik.

where are the ressource file you talked about ?


#10

wow…
I don’t have any Resources folder in my bundle.
I don’t know if it is normal for JuceDemoPlugin.component

if anyone know, I’d be happy :slight_smile:


#11

btw, I have some inconsistencies I hate …

I removed the whole project folder, copied the demo one, freshly, and edited through introjucer the jucer file.
tested a build and … same error as above:

what the hell ?!

if I could easily use another ide, I’d do that right now
I know I can, technically
but I’d need to edit some other files and couldn’t use introjucer after that :confused:


#12

Jules,
after to have been stuck, I reinstalled XCode (4.1) and restarted from the source Extras / juce.
Trying to build it, I had the first errors I had at the first times, and I didn’t have since about ambiguous stuff etc.

so I added AUBase:: (and AUMIDIBase:: to etc)
then
I had those errors:

/Developer/Extras/CoreAudio/AudioUnits/AUPublic/AUBase/AUBase.h:701: error: extra qualification 'AUBase::' on member 'MIDIEvent'
(at each place I added something)

so I removed AUBase::

then, I retried and … the same error:
Command /Developer/usr/bin/llvm-gcc-4.2 failed with exit code 1

I’m lost :frowning:

I HAVE to learn to set up a juce project from scratch in another IDE just in order to test…

if anyone could help me a bit, it would be great :?


#13

Why don’t you try it with normal GCC instead of LLVM?


#14

I tried.
I have an error too.

[code]CompileC /Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/Objects-normal/i386/AUDebugDispatcher.o /Developer/Extras/CoreAudio/AudioUnits/AUPublic/Utility/AUDebugDispatcher.cpp normal i386 c++ com.apple.compilers.gcc.4_2
cd /Users/julien/DATA/DEV/VST-PLUGINS/demo/Builds/MacOSX
setenv LANG en_US.US-ASCII
/Developer/usr/bin/gcc-4.2 -x c++ -arch i386 -fmessage-length=0 -pipe -Wno-trigraphs -fpascal-strings -O0 -Wreturn-type -Wnon-virtual-dtor -Wparentheses -Wswitch -Wunused-variable -D_DEBUG=1 -DDEBUG=1 -DJUCE_ObjCExtraSuffix=JuceDemo -DJUCER_XCODE_MAC_F6D2F4CF=1 -fasm-blocks -gdwarf-2 -fvisibility-inlines-hidden -iquote /Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/JuceDemoPlugin-generated-files.hmap -I/Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/JuceDemoPlugin-own-target-headers.hmap -I/Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/JuceDemoPlugin-all-target-headers.hmap -iquote /Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/JuceDemoPlugin-project-headers.hmap -I/Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Products/Debug/include -I/Users/julien/DATA/DEV/libsVST/vstsdk2.4 -I/Developer/Extras/CoreAudio/PublicUtility -I/Developer/Extras/CoreAudio/AudioUnits/AUPublic/Utility -I/Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/DerivedSources/i386 -I/Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/DerivedSources -Wreorder -F/Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Products/Debug -w -c /Developer/Extras/CoreAudio/AudioUnits/AUPublic/Utility/AUDebugDispatcher.cpp -o /Users/julien/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bvvbembmextleearyknqitsgtggs/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/Objects-normal/i386/AUDebugDispatcher.o

Command /Developer/usr/bin/gcc-4.2 failed with exit code 1[/code]

I’d love to find why it doesn’t work, how it had worked a bit this morning …
a bit…
I cannot write another thing


#15

Did anyone manage to solve this?

Past patching that bit of code that caused the initial compilation error, I too have this error on linking. I’m new to JUCE, so I’m trying this on a completely blank project… Interestingly, disabling AudioUnit in the Introjucer project works. I’m going to continue developing with just VST for now.


#16

In xcode try to change the base SDK ?

Salvator


#17

Hi there,

I’m facing the same issue trying to compule JuceDemo for iOS, device.

It works fine if I build the project for the emulator. But gcc failed with exit code 1 building JuceLibraryCode2.mm and JuceLibraryCode3.mm for the device target.

Same issue with XCode 3.2.6 and XCode 4.2.1, just trying to compile JuceDemo from Juce154 for iOS-Device, no change into the project.

Any idea?


#18

Gotcha!

It seems that “Compile for Thumb” option uncheck fixes the issue!

GCC_THUMB_SUPPORT = NO