Importing Aubio C library into Juce project


#1

Hi all

I'm still getting my feet wet with Juce and C++ in Xcode. 

I'm currently trying to get the Aubio (aubio.org) library to compile in the project. I'm importing it with IntroJucer. The problems I've come up against are:

Use of undeclared identifier 'stdout' (on fprintf error messages) - got round this by commenting out the offending calls (implemented as DEFINE statements). I'm not sure if this is a setting in Xcode or something else. 

Cannot find any library headers within subfolders in the imported source folder. e.g. 'spectral/fft.h' will fail, unless I change it to "fft.h'. There are a lot of files and includes in the library and would rather not tinker with them anyhow. I've tried to alter some settings in Xcode, and tried reimporting the library into Xcode without Juce. However then it can't seem to find any of the headers at all... 

Any pointers much appreciated. 

EDIT: got it working fine now by importing the framework and adding that to the Xcode project.


#2

Ok I got it to build by importing the framework instead...