Info.plist not generated


#1

Info.plist is not generated (anymore?) for my builds
running Xcode 7.1
Not sure if it is something I’ve done or not, since it probably been like this for a while and BitWig was the first host to reject loading VST wiithout (that I know of).
Is it a setting I can do in ProJucer or something I need to do in xcode?


#2

Builds/MacOSX/Info-VST.plist is generated by ProJucer
Nothing is copied/generated to final build result.


#3

The Projucer now builds a plist for every target and should copy the relevant plist into the bundles. If that’s not happening then it’s usually because your jucer file is still using a custom build script step. Make sure that this is empty:


#4

Thank you, after re-creating XCode build target without “Custom Plist” and “Post-build shell script” and “Pre-build shell script” it works.
I can’t help but thinking though that it would be nice to be able to add pre/post-build script/commands even when letting ProJucer handle Info.plist stuff. Preferable even different commands for Debug and Release.
Perhaps a separate checkbox for “let ProJucer handle Info.plist” or something could be useful.


#5

You can still add your own pre/post-build scripts.

The problem is a bit complicated: before JUCE 4.2, the .plist was generated by a post-build script (which - as a side effect - would delete other plist files), which JUCE would automatically add to your xcode project. With JUCE 4.2, we let Xcode make the .plist file for you (without a build script), however, if you now opened an old JUCE project with the Projucer 4.2 - and had ever edited the post-build script - then the Projucer would not delete that post-build script leading to errors in the build. All you need to do is remove the parts of the post-build script that try to generate a plist file. You can still put your own commands in there.


#6

Ah I get it, bit tricky indeed but it at least mean I can do post-build stuff, that is nice.