Introjucer and VS2010


#1

I got two issues since i tried migrating from 2008 to 2010

Introjucer is crashing when pressing the “Save and launch in VS” button (i deleted the VS2008 exporter and the VS2010 is the only one in the project)

case CommandIDs::saveAndOpenInIDE:
        if (project != nullptr && project->save (true, true) == FileBasedDocument::savedOk)
        {
            ScopedPointer <ProjectExporter> exporter (ProjectExporter::createPlatformDefaultExporter (*project));
            exporter->launchProject(); <--- CRASH here
        }
        break;

Second it seems that the compiler parameters don’t get passed “Extra compiler flags”, i tried a include statement

/I"BlahBlah"

and a /MP8 statement to do parallel builds and nothing gets to Visual Studio.


#2

Thanks, I’ll check those out…


#3

Didnt want to create a new thread, as the subject fits perfectly:

It would be great to have an architecture drop-down in Introjucer for the 2010 exporter (Win32, x64, and both). Including the architecture token (was it $(Platform) ?) in the default output directory and other critical paths would offer a kind of “Universal Binary” feel that builds 32 and 64 bit versions from one configuration.