Introjucer Does Not Create "Builds" Folder


#1

Hi Jules,

I compiled and ran the latest Introjucer from the tip, and it’s not creating the “Builds” folder… :? Am I missing something?


#2

Erm… Seems to work for me (on OSX). What should I do to reproduce this?


#3

Well, my steps are pretty straightforward:

[list]

  • Run The Introjucer from within VS2010 (typically in release… doesn’t matter in this case)
  • File->New Project…
  • (Change project name)
  • Change “Files to Auto-Generate:” to “Create a Main.cpp and a basic window
  • Select folder
  • Create…
  • Add Company Name
  • File->Save Project or click on “Save Project and Open in Visual Studio
    [/list]

Doing “Save Project and Open in Visual Studio” currently has no effect… My guess is because there’s no project to open.


#4

Ah wait, shit - I didn’t even notice the “Add a New Exporter”.

I guess I’d like to suggest generating a Visual Studio project when clicking “Save and Open in Visual Studio”!

Or even not have the button there until you add an “exporter”… Perhaps even the space where that button is could be used for the “add a new exporter” button?


#5

Ah, I see. Yep, I should disable the button if it can’t be used.