iOS apps stop working after a 4 or 5 days


#1

I don’t know what the root of the issue is, but I’ve put two of my iOS apps on my iPhone and both have exhibited this issue What happens is, I’m using my iPhone to test the apps I make with JUCE and Xcode, I don’t run the simulator, so a copy of the app is installed on my phone when I’m not testing. I’m also not a certified apple developer, so I’m known as an “unknown developer” and have to manually “okay” in the settings on the iPhone somewhere.

The apps run fine for maybe 4 or 5 days, but after a random amount of time, the apps will just crash every single time I try to open it. My latest app, a BPM counter, worked flawlessly for about 5 days until a few minutes ago, I tried to open it, and it crashed every single time. Nothing has changed. This may be an error on my end, but I’m not sure what it could be. I’ve tried removing the apps from ram and restarting the phone, but neither fix it. The only thing that fixes it is plugging the device back into Xcode and putting a fresh copy on it.

This is the current app that’s exhibiting the issue on my end, though the same issue occurred with another app I wrote too:

It should be noted I’m entirely new to JUCE and GUI development in general, so I’m betting I’m just doing something entirely wrong on my end.

Another note: the code is pretty mangled, I rushed to get it to work, more of me just trying to get into the idea of making iOS apps, as I’m still a major novice.

Update: I just checked the Settings>General>Device Management Section and the app that I had manually authorized in this section under my developer name is no longer authorized. Do apps that are from unknown devs and that are just product builds time out after so many days?


#2

If you don’t have a Apple Developer Account, the provisionary certificate is only valid for a week, after this you need to rebuild your app or it crashes. There’s nothing you can do about that except throwing 99 bucks at Apple (I had to do this recently to be able to run a private app on my iPod touch).


#3

Man, that’s absolutely lame. I can understand why a user would have to pay for a developer account for distributing to others, but to be limited on what you do with your own apps and devices stinks.

Anyway, thanks a ton for the confirmation :slight_smile:


#4

Yeah, it made me google “Jailbreak” for the first time in years again :slight_smile:


#5

Wow. I didn’t know this yet, but am not really surprised. For some time now, it felt like Apple devices are no longer your own anyway. More like luxury “terminals” providing temporary access to their closed ecosystem for a couple years, after which they become obsolete.

The other day I saw Apple stock listed under “Consumer Goods” rather than “Technolgy”, which is quite telling.