iOS Device Build Fails - Xcode 3.2.5, iOS 4.2


#1

The simulator build works, a device build fails.

With an amalgamated/single file build, it fails, 1 error, shows 30 or so - {standard input} nnnnnnn branch out of range messages.

With multiple amalg files, it fails twice, in the 2nd and 3rd files.

The juce static library builds fine.

Tried with jucer projects and the juce demo.

Bruce


#2

Sounds like a compiler error, but I’ve had it working myself, so not sure why it’d be different for you…


#3

Me either. I haven’t messed with anything - Mac, Xcode and juce as up-to-date as possible. And it’s just device builds - wait, I didn’t try a device release build. Maybe it’s just device - debug - arm7 builds?


#4

Hit the same problem when building the iPhone project last night, turned off Compile for Thumb in the project and target settings and compiled fine, but the app will not launch on iPhone now. Any clues?


#5

Getting the same errors as Bruce on the same two files using Introjucer. Weird thing is it was working yesterday (as I’ve been doing other things with iOS Introjucer projects and haven’t change my Juce version since then). This is on Xcode 3.2.6 iOS 4.3 though.


#6

Have you tried deleting all the intermediate files from the Xcode cache - I’ve sometimes had to do that to get around bugs in the incremental compiler.


#7

I had deleted the ‘build’ folder next to the xcodeproj is that what you mean? Restarted Xcode. Restarted machine.

BTW Release build is fine… although I was going to do some debugging so that’s not much use!

Turning off Thumb works though. And it does launch on the device - this is OK for what I’m doing right now.

Perhaps the code size just reached the limit again for iOS in those two amalgamated files. I only have 2GB of RAM, Jules I suspect you have more than that - would that be why you’re not seeing the problem?


#8

Could be. The thumb compiler certainly seems to struggle much more than the x86 one.


#9

Hello All,

Was wondering if anyone has made progress on this one? I am developing for an iPad, using Juce 1.53.97. Both the JuceDemo and HelloWorld demo compile and run in release targets, but both debug build targets do not compile

{standard input}:199080:branch out of range

for both LuceLibraryCode2.mm and LuceLibraryCode2.mm.

Simulator debug targets work great.


#10

Turn off “Compile for Thumb” in Project Settings->GCC Code Generation


#11

Thanks Aiit. That was it. Interesting that the Juce build does not like thumb instruction set for debug device targets.


#12

Sounds like a compiler error to me.