iOS linker errors


#1

Hello,

I am using OSX 10.8.5 XCode 5.1.1 and a fresh install of juce 3.0.7

I am attempting the most basic iOS test possible:

I opened up introjucer, created a GUI project with a basic window, saved and opened in XCode

it compiles and runs on OS X: Pink screen, 'hello world', everything groovy.

If I switch 'Build Settings -> architectures -> Base SDK' to 'iOS'. I get linker errors.

"ld: framework not found Carbon"

this is what I see in the frameworks folder:

Probably because the frameworks in red don't exist in the 7.1 Simulator library.

So in 'identity and type' I told XCode where to go find them all in System->Library.

Now they no longer appear in red, but I still get the same error.

Alternatively if I remove them, I get over 200 new errors.

Has anyone experienced this?

Is there some very basic aspect of trying to run juce code on iOS that I am missing?

Is there something I am not doing correctly in the introjucer?

Thanks for your help.

 


#2

You can't force an OSX project to build for iOS!

In the introjucer you need to create a new iOS target, which will create a new project specially for that.


#3

Hello Jules thank you for all that you do!

I figured as much, however, I had been clicking all over the introjucer to no avail.

I saw no way of creating a new target.

I finally discovered it is by right clicking on the top level in the config panel that a sub menu appears.

That was somewhat not obvious, maybe a little button would be awesome.

Cheers,

J


#4

Yes, you're not the first person to say that, I've been meaning to add something!