New error trying to compile the jucer with XCode 4.1


#1

I’m not sure all those errors are related to XCode 4.1 so I’d prefer to post them in case someone would find a common point etc.
(I mean it is more to help all of us, including me, than open a lot of thread)


#2

You have to include the AudioToolbox framework in your project for those symbols. That should get automatically included by the Introjucer. Are you using an old version?


#3

no old version.
I tested with the last fixed version and also with the last stems from a git clone freshly made.

how could I do that manually in Xcode?
(maybe I should test another ide… even if I have to set up all my juce projects manually)


#4

With 4.1 click on the Project Navigator, Targets, Build Phases and then Link With Libraries.

You could try XCode 3.2, I think thats still available. Any non-XCode IDE on the Mac is asking for trouble when using the Apple API’s from what I’ve heard.


#5

I added /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.3.sdk/System/Library/Frameworks/AudioToolbox.framework/Headers in the search path
and
/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.3.sdk/System/Library/Frameworks/AudioToolbox.framework in the search frameworks path (recursively)

all the same.

why the introjucer doesn’t work correctly?
this was the first thing built with xcode this morning and the build has worked fine.


#6

Is this OSX or iOS you are compiling for? If you followed the steps I posted it should find the right framework for your current development target. For OSX my AudioToolbox framework is located at /System/Library/Frameworks but I would let XCode choose the most appropriate source for you.


#7

I don’t understand why I have to make that.
It worked so fine for VS express on win.
I need to build for osx too.

About what you proposed, I tried to add audiotoolbox lib and

IT WORKS.

thanks a lot.
now, the other compilation http://rawmaterialsoftware.com/viewtopic.php?f=2&t=7862
but I’ll try to add AU lib maybe