Is it possible to create a file browser from an AUV3 effect on iOS?

Hi, is it possible to do this?

I’m making the call and nothing happens - looks like it’s working but nothing is being displayed. I’ve tried passing a number of things as the parentcomponent parameter.


Yes it works if you pass your editor as parentComponent in the FileChooser constructor and use launchAsync to show it.
We are on JUCE 6 here

1 Like

thx for your reply - can you check what type parentComponent is for you? I’m having no luck. thx!

I remember that i also could not open the browser in a sandboxed AUv3 application even when i pass the path to the sandbox file location.

Also very interested in a solution for this.

1 Like

Hm … i really didn’t do anything special there … just:

    auto browser = std::make_shared<FileChooser>(translate("Open Kit"),
        File(searchDir), "*." KIT_EXTENSION, true, false, this);

                         | FileBrowserComponent::canSelectFiles,
                        [this, browser](const FileChooser &){


as parent component i pass an AudioProcessorEditor instance…
That’s assuming you are using the native dialog. The JUCE dialog wouldn’t work on iOS

1 Like

thx - i’ll reconfirm tomorrow but I think this is exactly what I’m doing? Are you sandboxed? thx

I’ve confirmed this is what I’m doing but I’m not seeing anything :frowning:

@luzifer I’ve just created a fresh auv3 plugin and tried to launch the browser from inside it (running inside AUM) and nothing appears. Guessing something else must be happening inside your app…?

Hm … this is really wired. I just tried to re-run an old project i had lying around just to try things like the open dialog before committing to the full port of our app. I used FileChooser as in my code block above and it works fine on unmodified JUCE 6. Which version are you using?

So far as i know all apps and plug-ins on iOS are always sandboxed so i don’t quite understand the question.

I just checked and the example app doesn’t have any special permissions or capabilities.

1 Like

I’m building on Juce 7 - will try on 6.

I wonder what the file browser shows. It does not make sense if it shows the public folders. You can’t save or load anything from there. Does it show the sandboxed directory?

Apps are not sandboxed the same as AUv3 plugins. In Apps you can access public folders and cloud. In the AUv3 you only have access to your own sandbox folder. At least this was the case a few years ago.

Edit: Because of this you find browser projects on github especially written for sandbox access. As i said, maybe this information is outdated.

just to make sure we are talking about the same thing ….
you do mean the file picker dialog?

1 Like

Yes, something like this. This looks great. Is this your sandboxed AUv3 folder? Did you start it in garage-band?

It isn’t the sandboxed folder. Using the native file chooser a user can open any file of their liking regardless of location or storage provider. It works on all hosts we tested and the app is on the app store since mid june.

Ohh, yes. That’s exciting. We can now access the public app folder and the cloud drives from the AUv3 plugin!?
I will work on my AUv3 app in a few weeks. Hope I can also add this.

1 Like

yep, that’s what I’m after - just can’t get it working.

is it working for you??

I know that it didn’t in the past. I’m currently working on something different. I will try in a few weeks. Maybe we need to configure and set some key values (entitlements) to make this work.

Here is a thread about this topic how i also thought it works:

Edit: Looks like reading files should be possible with the native file dialog. Just writing files does not work.

Just pulled 6.1.6 and it works fine - must be a juce 7 issue!