Issues with building ROLI Blocks example projects


#1

Whenever I attempt to build one of the Blocks example projects, I get an error 'Allocating an object of abstract class type ‘juce:PhysicalTopologySource::Internal::TouchSurfaceImplementation’.

I’ve tried saving it through the Projucer and nothing changes. Could it be something to do with using XCode?

It seems to work fine after I comment out a virtual function in the TouchSurface class.

//virtual int getNumberOfKeywaves() const = 0;

I’m still curious if there is a better solution.


#2

Did you create the getNumberOfKeywaves() method in the derived class? Or are you trying to use an abstract class directly?

Rail


#3

I created a new Console Project, imported the juce_blocks_basics module and I am getting the same error message.


#4

Are you on the develop branch? That method is definitely implemented here:


#5

I had been working out of the folder from the website download.

After cloning from the developer branch everything works fine.

Thank you very much for the help!