JIT engine breaks if Projucer 4.0.1 run from path containing whitespace


#1

Hi chaps,

I'd like to have a play with the Projucer's JIT compilation features, but I'm not having any luck. I've registered on My ROLI for the free/community tier and downloaded JUCE 4.0.1 to my Mac Pro (OS X 10.10.5, Xcode 7.1.1, 2.26GHz 8 core, 12GB RAM, SSD boot drive). I've succesfully logged in and the Projucer is displaying the Build tab, but when I attempt to open one of the example projects it goes something like this:

  1. Open Projucer, close any open projects
  2. File > Open > point it to "~/juce-grapefruit-osx/examples/Demo/JuceDemo.jucer"
  3. Approximately 20 seconds elapse whilst nothing appears to happen
  4. The Projucer window opens on the Build tab and displays the message "JIT process stopped responding!"
  5. From the Build menu, I click "Enable Compilation"
  6. Another 20 seconds or so elapse whilst nothing appears to happen
  7. The left hand sidebar of the Build tab now shows the accordion GUI - "Errors and Warnings, Components, Activities", but the Components area is empty.
  8. Any mouse clicks around the Projucer (e.g to the Config tab, and then to one of the modules) result in 10-20 seconds of beachball before the expected behaviour.
  9. Click back to the Build tab
  10. Wait another 10-20 seconds for the beachball
  11. The components area of the left hand accordion is still empty, but now the right hand pane is eroneously showing a live version of the Module editor previously selected on the Config tab for editing.

I have tried also opening the HelloWorld, AudioAppExample and PluckedStringsDemo on my Mac Pro and MacBook Pro (also OS X 10.10.5) with similar results. It certainly isn't behaving as I would expect from having watched Jules' (old) YouTube demo.

frown Am I doing it wrong? 


#2

Apologies, it's still early days for the Projucer (we only restarted development earlier this year)! The demo projects worked fine for us internally, so there must be something about your set up that's exposing some flaws in our code. Could you provide some screenshots for point 11?

Thanks for the report!


#3

Thanks Josh for your reply. I think I've figured out the STR on this one.

As far as I can tell, if the Projucer application resides at a path containing whitespace

e.g. ~/My Current Project/juce-grapefruit-osx/Projucer.app

it (mis)behaves as described in my original post, remove the spaces from the path

e.g ~/MyCurrentProject/juce-grapefruit-osx/Projucer.app

and it behaves as expected. It seems to be the path to the Projucer that matters, not the path to the project.

Here's the screenshot for point 11 above.


#4

Good spot! That would explain why it works for us, but not for you.

Regarding the Dropbox link, I can't view it (no permissions).

Thank you for your efforts!


#5

Thanks Josh. I've fixed the screenshot URL, but I don't think it's all that relevant to the bug report.

The behaviour in the screenshot was only confusing because I wasn't having any luck getting the Components area to populate; now that I've got things going, I can see that you can have a Module editor up on the right hand pane whilst you're on the Build tab in the left hand pane.