JIT process stopped responding


#1

Hi,

I’m trying to use the Projucer from JUCE 4.2.4 on MacOSX with the live compilation engine and don’t seem to be able to get it to work. I’m on OS X 10.11.6 with Xcode 8.0 (8A218a). When I go to the ProJucer Build tab and restart the compiler, I can see the build progress in the Activities panel. It finalizes with “Initialising JIT engine…” but then fails with the message “JIT process stopped responding!”. I also tried this with the the JUCE example apps (like HelloWorld) and the same happens.

Any thoughts on what might be going on?

Thanks for the help!



#2

Are you mixing different projucer and live build dll versions?


#3

Not that I know of, I downloaded JUCE from the website, simply executed ProJucer from the unzipped archive. Are there other places that the live build DLL is being looking for?


#4

Hi gbevin, thanks for reporting this and providing so much info! I have OSX 10.11.5 here and I will check with Xcode 8.0 asap.

Are there other places that the live build DLL is being looking for?

The Projucer looks for the DLL:

  • in the App’s directory first
  • in the App Bundle second (Mac only)
  • in /Users/<user>/Library/Application Support/Projucer-<version>/ last

#5

Thanks Stefan, I have no DLL in that user directory, so it should only be using the one that’s in the ProJucer app directory.


#6

Unfortunately I cannot reproduce your issue straightforward on OSX 10.11.5 with your exact Xcode version…

Can you please go to /Users/staehff/Library/Logs/com.juce.projucer and check the latest Compiler_Log text file? Does it have any further information other than this?

Projucer 4.2.4 — Build date: Sep 30 2016
Log started: 7 Oct 2016 11:12:16am


#7

Nothing else than this in the log file:

Projucer 4.2.4  ---  Build date: Sep 30 2016
Log started: 7 Oct 2016 11:45:31am

However, I’m on OS X 10.11.6, you’re on 10.11.5, maybe that has got something to do with it?


#8

However, in IDE_Log I see this:

**********************************************************
Projucer 4.2.4  ---  Build date: Sep 30 2016
Log started: 7 Oct 2016 11:49:20am

Mac OSX 10.11.6
CPU: 2700MHz  Cores: 8  16384MB
Loading project: /Users/gbevin/JUCE/examples/HelloWorld/HelloWorld.jucer
*** Child process crashed:

The child process crashed message corresponds to the JIT process stopping responding.


#9

Thanks for checking. Getting the logging right from the separate compile processes is not trivial… However, I think we really need to fix that soon.

For the time being: First I didn’t expect the 10.11.6 OSX update to introduce any relevant changes, but then I googled and found a lot of people complaining about bugs. So you’re probably right with updating to 10.11.6 and check again.


#10

Same thing after updating to 10.11.6, works on my machine :confused:
Can anyone else reproduce the behavior Geert describes?


#11

Anything I can do to help you track this down? Maybe run a debug build of the DLL?


#12

I’ve been getting that message a lot but haven’t checked into the logs described above yet. Will be back at my dev machine tomorrow and I’ll report back.


#13

Sorry things got busy in the office and I forgot to reply to this. I’m getting the same ‘JIT process stopped responding’ message, and when I check the log files mentioned above I only get the ‘*** Child process crashed:’ statement too.

This is with a brand new GUI Application doing nothing but drawing a window and filling it with a colour. OS X version 10.10.5, latest master branch of JUCE, Projucer downloaded from the website (v4.2.4, build date 16/09/16).


#14

Thanks DBarr, good to know I’m not alone with this problem!


#15

This may actually be a SDK problem. The 4.2.4 release of Projucer and live build engine were build with the MacOSX10.11.sdk, but Xcode 8 is shipped with only MacOSX10.12.sdk. This seems fine for the Projucer to run, but not for the live build engine to compile/load/execute.

In order to fix this for the 4.2.4 release, please add either the MacOSX10.10.sdk or the MacOSX10.11.sdk to your Xcode app bunlde. You can get the SDK from old versions of Xcode (unfortunately Apple does not offer downloads for the SDKs alone). Step by step:

  1. If you have Xcode 7 at hand, great. Otherwise, you can download it (when signed in with a Apple account) here: http://adcdownload.apple.com/Developer_Tools/Xcode_7.3/Xcode_7.3.dmg

  2. In the Xcode app bundle, you can find the SDKs in:
    Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

  3. Copy the missing SDK over to the same path in the Xcode 8 app bundle

  4. Open the Projucer, do ‘Build → Clean All’ to remove cached files and check if it works now

Please let us know if this helped and which SDK you chose. Thanks again for your patience. In future releases we will detect this issue and show a warning.

Cheers
Stefan


#16

Hey, it seems much more stable with the 10.10 SDK after a quick test. I’ll have a a more thorough play around with it as soon as I can.


#17

I’m having the same problem running XCode 8 on 10.11.5. Going to add the 10.10 SDK and see how it goes. I’m not sure if this is still an ongoing issue but Stefan’s solution is the one thing I can find when Googling.


#18

There is still no solution to this? I have Visual Studio 2015 Community and I’m getting the exact error “JIT process stopped responding!” … From the other PC I’m running it without any issues. There I have Visual Studio 2017 Community. Doubt VS version causes this issue tho.


#19

Can you try the latest version? See this post


#20

I’ve seen that and I’ve tried it already. Did the reinstall several times and tried the deleting dll file. No results unfortunately.