Visual Studio 2017: JIT Process Stopped Responding

jit
projucer
windows

#1

I’m using JUCE with Visual Studio Community 2017. I’ve installed the following Visual Studio components:

Workloads

Universal Windows Platform Development
Desktop development with C++

Individual

Windows 10 SDK (10.0.15063.0) for UWP: C++

And when I try to launch any of the examples (i.e. Hello World) from within Projucer I get this error:

JIT Process Stopped Responding


#2

I’ve been investigating this today, it’s a really strange bug and could take a while to track down but we’ll push a new version of the live-build engine when it’s fixed.


#3

Is this issue specific to my configuration of VS? I’d be willing to switch to another version if it would be more stable/compatible with JUCE.


#4

i’d be glad to help diagnose this issue. please let me know if there is any more information i can provide or tests i can run to help in finding a solution. I’ve checked the logs in AppData/Roaming/com.juce.projucer and nothing is helpful in the compiler logs, but the IDE logs have a line with:

*** Child process crashed:

Let me know if there is anything else I can do.


#5

This should be fixed with the release of 5.1.1 today. If you’re using the prebuilt Projucer binary downloaded from the JUCE website it will have the new live-build engine embedded already but if you are building the Projucer yourself you’ll need to delete the old dll and download the new one - this post explains how to do that.


JIT process stopped responding
#6

Hi, Same issue here, VS2017, Win10 x64 15063.483
I have built V5.1.1 and downloaded latest compilation engine dll
but I still get the “JIT process stopped responding” whenever I try to run a component.

I’ll try to install VS2015 side by side to see whether I can workaround on this for the time being.

If is there anything I can try to help pinpoint the issue let me know,


#7

Ok, when target is VS2015 this issue does not arise and live coding works as expected.


#8

what version of VS2015 do you have? have you customized the install at all?


#9

VS2015 update 3, just added C++ support during package selection


#10

The 5.1.1 update appears to be working with my VS2017 install. I’ll try your loadout if I run into any more problems.


#11

This thread seems to be a couple of months old now, but I’ve just started to experience this issue and it’s doing my head no good. I’m running Visual Studio Community 2017 v15.5.2, JUCE v5.2.0 on a Windows 10 machine. The JIT engine just keeps crashing giving the message “JIT process stopped responding!” This only seems to be the case for the 10.0.16299.0 and 10.0.14393.0 Platform Targets. With earlier targets JIT runs fine, but then I have multiple missing header errors instead. Linking to the relevant kit (C:\Program Files (x86)\Windows Kits\10\Include\ … ) in System Header Paths doesn’t fix either issue, and neither does deleting the JUCECompileEngine.dll and letting the Projucer reinstall it. I’ve literally tried every combination of Toolset and Target Platform for VS2017 and VS2015 with the same result, either a JIT failure or missing headers. I also tried to export to Codeblocks as a last resort but with a similar JIT failure. What I did notice is that the Projucer flies upto 100% CPU just before the JIT crash in Task Manager. Any help would be very welcome!


#12

Just a quick bump on this thread as I’ve tried a few things to no avail.

I’ve just completed a complete system reset, so I have a fresh and clean install of the latest version of Windows 10, fully updated along with all of my drivers. I have installed the latest version of Visual Studio 2017 Community, with just the Desktop Development with C++ Workload installed. I have also installed various toolsets from the list: Windows 8.1 SDK and UCRT SDK; Windows 10 SDK (10.0.16299.0); Windows 10 SDK (10.0.15063.0); Windows 10 SDK (10.0.10240.0); VC++ 2015.3 v140 toolset. I’m also running JUCE 5.2.0. I’m still experiencing “JIT process stopped responding.”

The relevant SDKs all seem to be in the correct folders (C:/Program Files (x86)/Windows Kits/…), but the live build engine crashes with all of the Windows 10 target platforms, and it can’t find some headers if I use the 8.1 platform. I can “force” the 8.1 platform to find the correct headers by adding the system header paths manually, but then I experience the same “JIT process stopped responding!” error as before. I’ve again tried to create exporters for VS2017, VS2015 and Code::Blocks. No joy at all with this. I have absolutely no problem compiling with Visual Studio, Qt and even RackAFX projects. I’m not sure if Microsoft changed the header locations in the latest MSVC update, or whether the header content has been changed, but it seems to me like JUCE is having some issue with them.

If I go to C:/Users/UserName/AppData/Roaming/com.juce.projucer all of the log files have the following: *** Child process crashed. And as I said in my last post, Task Manager flies upto 100% CPU just before the JIT engine decides to give up. I’m on a fairly fast machine, i74930 hex core with hyperthreading, overclocked with 16GB RAM, so I wouldn’t have thought that was an issue.

Any help would be very welcome right now, I’m itching to get this thing up and running.


#13

I"m seeing the exact same problem. With the ‘default’ target header files are missing, with the 10.0.16299.0 target the JIT stops responding.

This happens with both, the Projucer from the JUCE download packages as well as with a self built Projucer from Github master and a build engine downloaded and installed.


#14

I’ve had a look at this and it’s a bug in Clang that needs to be patched, I’ll hopefully get it fixed next week.


#15

OK this should be fixed now. You’ll need to delete and re-download the live-build engine to get the fixed version, this post explains how to do it.


#16

Selecting the ‘default’ Windows target still does result in missing header files. Using ‘10.0.16299.0’ does work but gives a compile error in a Projucer file. Pls. see the attached screen shot.

Anyway, thanks a lot for looking into this!!


#17

Ah yes, you’ll need to be using a version of the Projucer built from the develop branch.


#18

Works like charm! Picture a happy face :grinning:


#19

Thank you for this, ed95!

I just installed the latest JUCE 5.2.1 and now everything seems to be working correctly. Back to normal operation! :smiley:


#20

Unfortunately I’m also being bit by this. VS2017 with 10.0.16299.0. Happens with 5.2.1 as well as Projucer compiled from the develop branch (checked out today). I’ve forced redownloading of the compile engine and ended up with JUCECompileEngine 5.2.1.0 (md5sum is 0594b094f319bccd3ea91f11aa978893) but I’m still experiencing exactly the behaviour described here. (i.e. “Initialising JIT engine” each time a build is triggered until eventually it just says “JIT process stopped responding”)