Problems with Projucer and VS2017 community edition

projucer
#1

EDIT2: It seems like I got it working now. I deleted my JUCE folder, redownloaded it and unzipped it into C:\JUCE. Formerly I was using C:\Users\myusername\development\JUCE, so that might be part of the problem. I’ll retest this later on and leave this post here, if someone else runs into similar problem.

Hey! I have been trying to get JUCE work for few days now. I’m using Win 10 pro on a Dell laptop, newest Juce and VS 2017 community edition. I have tried various solutions I found in the Juce forums, but none of them seems to work for me. I have not worked with c++ projects before, so maybe it’s just something about include files that I can’t right, but shouldn’t those work right out of the box when using Projucer?

I’ve tried a demo project, and making a new GUI and VST application. I tried using two different WIN SDK’s (latest one and 10.0.16299.0). I’ve set the module paths manually and globally, and copied them in the project folder.

When using the Live Build Engine, I either get ‘JIT process stopped responding!’ or error about missing files.

With VS 2017, I get this output when building: pastebin
I can see all those missing files in my Solution explorer panel just fine.

I was able to install JUCE on my desktop computer, which also has WIN 10 Pro, and it worked there without any problems. I even tried to reinstall VS2017 and JUCE on my laptop, but problem persists.

EDIT: I also tried downloading JUCE from github and building it with VS, but got similar errors, and failed building the projucer app.

Anyone has any idea why this is and how I could fix it? Thanks!

0 Likes

#2

Well, personally I am not using the LiveBuild feature.
Instead I open the JUCE project directly in Visual Studio 2017. You know that you can do that, right?
But if you want to test the live build, you can check out the following forum thread:

1 Like

#3

Yes, I am using VS, I just put those Live build errors there to provide more information. But it seems like I got it working now, I’ll put my solution at the top of my post.

1 Like