Projucer Live Compile issue - Windows 10


#1

Hi All,

I’m currently working on a new Windows machine and have tried to use the live compile feature today to see if I can speed up the process of writing a few GUI Components.

I’m running Windows 10 and the JIT process keeps crashing out telling me various system headers cannot be found.

For example ‘memory’ file not found in juce_StandardHeader.h amongst others.

The live compile engine runs just fine on my other Windows 10 machine but I’m having issues getting things working on the new one.

I’m able to otherwise build the same components and projects on this machine with JUCE and VS2015 but the JIT engine is dying on me.

EDIT: This is using the latest develop branch built Projucer (So I could use the dll download feature)

Any ideas ?


#2

Just giving this a quick bump as it was posted over the weekend in case anyone can point me in the right direction.


#3

Hi, thanks for reporting. Can you please check whether you have the missing headers on disk in this folder:
C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include

Thanks!


#4

Hi @stefan.graenitz

As far as I can see the relevant headers are actually in the below path on my system.

C:\Program Files (x86)\VC\include

Sorry I’m a little new to CPP on Windows/VS. I’ve mostly developed on OSX and Linux but need to do some Windows work (dead mac) and I’m in love with Resharper.

Is there an obvious way I should remedy this ? I’m hesitant to mess around as my projects are otherwise building without issue referencing all relevant headers and I can’t afford any major delays at the moment…

Cheers Stefan.


#5

Ok, you can try adding this path to the “System header paths” under Live Build Settings (Config tab). It may work, but no guarantees as these headers are vendor specific and must always be included first, which is not guaranteed in this case.

As far as I can see the relevant headers are actually in the below path on my system.
C:\Program Files (x86)\VC\include

Did you run a custom installation for Visual Studio 2015? Because from what I know these headers always go to:
C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include


#6

Hey Stefan,

Thanks for the late reply. I will give that a go.

Nope nothing special with the install as far as I can remember. Just the various C++ packages and extensions and VS 2015 Community download.

I’ll take another look into it though and let you know if this works.

Cheers


#7

Yep. Awesome.

Worked right off the bat adding that path to the System header paths (Little embarrassed I hadn’t already tried that…).

Still unsure as to how I ended up with the headers in that location. I might dig further to work out what’s gone on during that install but for now it works and I need to get a hussle on so thanks a bunch for the help Stefan.

Josh


#8

i’m getting the same errors on OSX when attempting to do a BUILD inside PROJUCER.
The exact same project ( plugin ) compiles fine with 4.3.0 in Xcode.

BTW the Xcode project was cleanly created from the PROJUCER and nothing was tweaked in Xcode…


#9

Hi nonchai, the Standard Library headers should be installed along with Xcode. So I am a bit confused by the fact that you have a working Xcode, but no memory header in the default location… can you please check if you got the file in this folder:
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/c++/v1

Thx


#10

getting the same errors, memory and windows.h cant be found. the “VC” folder of vs2017 didnt have a folder named “include” in it. ive tried downloading a windows sdk and dragged the folders into the “include” folder that i had created, still nothing works tho.
Its a bummer that i cant use the projucer because of that, vs2017 still works fine tho. also online i could only find outdated information about windows.h missing etc.

oh and i had used the projucer a year ago on an older windows installation and it worked perfectly fine there


#11

Same problem here, VS2017 only (no former versions installed), Win10, Projucer 5.0.0.


#12

been trying to sort out the same issue for hours now. tried a fresh install of VS2017 community twice. cleaned registry etc.

the problem seems to be that the header files do not install correctly using the VS2017 installer program. i don’t know if it is due to incompatibility problems with the windows driver kit WDK and VS2017 or should the missing headers be included with the UCRT SDK or Standard Library Modules or some other optional component. tried them all but anyway the header files can’t be found after the VS installer finishes.

there seems to be a tradition of the similar problem every time there’s a new version of VS, but the solutions available online are outdated like mentioned before.

Win10/projucer 5.0.0.


#13

This should be fixed in the latest version of the compile engine - see this post for how to get the latest version.


#14

Hi!
I have some issues when I try to compile a project in JUCE5. There are some include files not founding (e.g. memory, windows.h).
I see this files in the folder: C:/Program Files (x86)/Microsoft Visual Studio 11.0/VS/include
I have Windows 8.1 and update to JUCE5 and VS2017.
This problem was not with JUCE4.
Is this can be because of the old version Visual Studio installed before?


#15

Can you see the files in C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\include? This is where they should be for the current version of VS2017


#16

Yes, but just on disk D.
D:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\include
I use D to install programs, since C is already full.
Need somewhere to point the path to drive D?


#17

Can you try putting that path into the “System header paths” section of the live-build settings? If you click the setting cog icon in the bottom-right corner of the live-build tab it’ll take you to the settings page where you can paste the path into the text box


#18

Thanks, I’ve done and "memory’ was found. But “corecrt.h” and “windows.h” is really absent in include folder. Now error only with this two headers. What can I do with this?


#19

These should be located in the include folder of the ‘Windows Kits’ directory which on Windows 8 is located at:
Program Files (x86)\Windows Kits\8.1\include

For Windows 10, it’s at:
Program Files (x86)\Windows Kits\10\Include\(your Windows platform version number)

So if you add this to the system header paths it should get rid of the errors however you’ll probably run into other include issues, is it possible for you to do a re-install on disk C?


#20

Well, thanks for the quick response. I’ll try to reinstall VS on disk C.