Win Live Build?


#1

I was just testing the Projucer Live Build on Windows.
Does anyone know, if it is working at the moment?

For me it fails, saying that the include file “memory” cannot be found.
The thing is: memory.h is included by the JUCE code itself. More specifically by “juce_StandardHeader.h”
See also attached screenshot.

Is there some additional settings I need to do, in order to make the LiveBuild work and in order to tell it, where to find “memory.h”?

Note for completenes: If I build my project inside Visual Studio 2015, then there is no problem and the memory.h file is successfully found. So the file is on my computer. Only the Projucer does not seem to know where to look.


#2

– Bump –
Nobody is using this?


#3

The missing memory.cpp error usually comes from not having the windows 10 SDK installed


#4

I started out with the same error. But adding this “C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include” to the “System Header Paths”, and updating “Windows Target Platform” to the newest solved those issues.

Now I’m stuck with the following error (ISO C++ 17 does not allow dynamic exception specifications):

The “C++ Language Standard” is set to Default (C++14).

Any advice?

I have selected Visual Studio 2015 as exporter.


#5

I have the exact same problem. I’m also using Visual Studio 2015 (on Windows 10).

@Alatar, did you manage to solve this somehow? Or maybe some of the pro Jucers can help?


#6

No, I did not solve the problem yet.
Unfortunately I did not have time to test, either.


#7

@tpoole, @ed95 do any of you know if live build works with Visual Studio 2015? I’m using the Professional edition.


#8

Yes it should work for VS2013 and up. You’ll need the Windows SDKs installed somewhere on your C drive as @Im_Jimmi says above.


#9

Hmm, strange.

I’ve installed the latest Windows 10 SDK supporting VS2015 (10.0.17134.0) at the default location (c:\Program Files (x86)\Windows Kits\10) and I get the ‘memory’ file not found error. I changed the Windows Target Platform to 10.0.17134.0 in both the Live build tab and the VS2015 exporter tab. When looking in the sub folders of c:\Program Files (x86)\Windows Kits\10\Include\10.0.17134.0\ there is no memory file (a memory.h file exists but that’s not very helpful).

I tried adding C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include (in this folder there is a memory file) to the System Header Paths but then I get the ISO C++ 17 does not allow dynamic exception specifications error.

I also installed the 10.0.16299.0 SDK but this gives the same errors.

@ed95 do you have any idea about what is causing this? Where is the memory file supposed to be located?


#10

That all looks correct. Can you try installing VS2017 (community edition) and see if the errors go away?


#11

Installing VS2017 Community Edition solved the problem. I can now run the demo projects in Live mode.

Thanks for the help!


#12

OK great. When I have some time I’ll dig into why VS2015 wasn’t working.