A newbie that can't even start! Please help!


#1

Hello, I’m a Juce beginner and I want to make some audio plug-ins using you professional looking software.

So I run Projucer, and click on new audio plug-in.
Point it to Juce’s Modules, select VS 2015 and set the project name.
I click Create, and I get a list of 4 files, that seem appropriately named.
BUT when I click Enable Complilation I immediately get ‘memory.h’ and ‘windows.h’ not found errors.
So I can only conclude that it’s not finding any of the Windows includes.
What’s happening please?
*Edit I’m using Windows 10 and projucer 5.1.1 and none of the previous forum posts help, because everything has changed.


#2

You probably want to open your project in Visual Studio instead of using the live-build engine, which is what the ‘Enable Compilation’ option is doing. To do this, select the Visual Studio version that you have installed from the drop-down menu at the top of the Projucer and then click the VS icon next to it - this will save your project and open it in Visual Studio:

A good way to start learning JUCE is by reading the tutorials, here.


#3

Thanks for a prompt answer, so I can’t use ‘live’ build at all!?
That’s a disappointing start. :frowning:

I only have one option in the Exporters list, so how do I make an MacOSX version of my plug-in?
Do I have to start again?


#4

Not at all. Make sure no exporter is selected (nothing yellow) and click the plus button in the lower right corner. Select under “Create a new export target” the platform, you want to support.
Note, to actually compile for OSX, you need to run XCode on OSX. Cross compilation is not supported out the box (if at all).

HTH


#5

You can add new project exporters later without starting over by pressing the + button under the exporters list. (You will need a Macintosh computer and XCode installed on it in addition to Juce to build the project, though. Hopefully that didn’t come as a disappointing surprise too…)


#6

Excellent! Thanks Xenakios/daniel! I have an iMac with xcode for my other plug-in work.
Not having Live build is a disappointment I cannot escape from, sorry. I just don’t understand why not.


#7

It would be a question for @ed95, if this is just due to a bug, that might go away in the near future, of if the projucer is not meant to compile plugins at all…

I always dreamt of an integrated Projucer-live coding-debugging solution, that you might even be able to step debug through dsp cycles with wave generators or file readers as input… there is still some potential…


#8

OK I going through this tutorial, and when I open the host example in VS it compiles with an:
"\plug-ins\juce\modules\juce_audio_processors\format_types\juce_VST3Headers.h(89): error C1083: Cannot open include file: 'base/source/baseiids.cpp"
even though I’ve downloaded vst sdk today and set the global search path in projucer.


#9

memory.h and windows.h should be located in the Program Files (x86)\Windows Kits\10\ directory. By default the live-build engine looks for these under the 10.0.15063.0 subfolder but if you have a different version of the Windows 10 SDK installed then you’ll need to set this in ‘Windows Target Platform’ drop-down of the live-build settings:


#10

Thanks for the heads-up, so it’s no good having vs 2012 and 2015 because I don’t have the separate Windows SDK installed.

I’m still getting the baseiids.cpp class error from above.


#11

If you add the VST path to the projucer, make sure it is not displayed in red (otherwise it is not correctly found).
IIRC it has to point to the VST3_SDK folder inside the VST_SDK… that might be the confusing bit.


#12

Thanks, it’s very confusing because this page:
https://juce.com/doc/tutorial_create_projucer_basic_plugin
…shows that I choose the VST_SDK folder above it! - And it doesn’t go red if I do.
https://juce.com/doc/tutorial_create_projucer_basic_plugin_0.png


#13

I just double checked, it only goes red, if the folder doesn’t exist. But it doesn’t tell, if it is the right or the wrong one.
So for me it works, if I pick the VST3_SDK inside, so maybe worth a try…


#14

It doesn’t help that most of this is wrong :slight_smile: - "If you have the VST 3 SDK you can add the same path top both the VST SDK and VST3 SDK fields. If the paths are correct they should be displayed in black text (or red if there is a problem)."
There are no such fields and the text doesn’t go black, the diagram shows the VST_SDK and it’s in white!
I’ve installed the latest Win SDK and now it says the ‘JIT stopped responding’ after a host of unreadable errors flash up. GRRR, not a good start today…


#15

Installing VS 2017 Community edition seem to clear up a lot of problems for me today. I still have some VST3 wrapper compile errors, but the Projucer works much better now, and I can enable compilation on it. :sunny:

Thanks again, and please sort out your web page tutorials, following out of date or misleading words is an annoyance - (see above quote)
Dave H.


#16

The tutorial has been fixed. It will get changed online next time there is a website update.


#17

The image still shows it pointing to the wrong vst directory, it should be …\VST3_SDK


#18

Thanks for your persistence! The image will also be changed next time there’s a website update.


#19

I see it still hasn’t changed. The image still doesn’t have a 3 in the SDK folder selected, which is misleading.


#20

There should be a website update sometime later this week.