Juce 1.42 Build Error (juce_positionedrectangle.cpp)


#1

Hello all

I have made a “make CONFIG=Release”, as explained in the doc, but it crashed with those lines :

juce_PathStrokeType.cpp juce_Point.cpp make[1]: *** Pas de règle pour fabriquer la cible « ../../src/juce_appframework/gui/graphics/geometry/juce_positionedrectangle.cpp », nécessaire pour « ../../bin/intermediate_linux/Release/juce_positionedrectangle.o ». Arrêt. make: *** [JUCE] Erreur 2
(yes it’s in french, i am)

Sorry if this bug is already fixed, i’ve searched…

edit: i’m running Debian Etch

Thanks :slight_smile:


#2

i think you should update to the latest svn version, or at least to 1.43…


#3

1.43 crashes too, with other messages :?
I will try the latest versions, but i don’t know anything about SVN…

Where can i find svn versions ?


#4

something like this:

$ apt-get install subversion $ cd MyProjects && svn co https://juce.svn.sourceforge.net/svnroot/juce/trunk juce

hope this helps :slight_smile:


#5

1.43 builds just fine here, also on debian etch.

Did you run the premake script again? Because the default one doesn’t always work for some reason.


#6

Thanks for your answers :slight_smile:

[quote=“Rock Hardbuns”]1.43 builds just fine here, also on debian etch.

Did you run the premake script again? Because the default one doesn’t always work for some reason.[/quote]
I have just installed premake, but the program itself doesn’t work

[quote]premake: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4’ not found (required by premake)
[/quote]
I can’t find this package :confused:


#7

Download the source package and build it. It’s a simple build. Just unzip and type “make”… takes 2 seconds.

…and the take the binary from the bin dir and drop it in /usr/local/bin or where ever you like to keep local builds.


#8

[quote=“Rock Hardbuns”]Download the source package and build it. It’s a simple build. Just unzip and type “make”… takes 2 seconds.

…and the take the binary from the bin dir and drop it in /usr/local/bin or where ever you like to keep local builds.[/quote]
I did it, and when i type “premake” or “premake [anything]”, it gives me the message above…


#9

That’s odd. Are you certain that you don’t have the pre-built version loitering somewhere in the “path”.

I’m not sure how this stuff works, but I got the same message with the binary version, but the one I built my self worked. Probably because it linked against the version of Glib I have installed.

Having the build go all right, but then not run is sort off voodoo-ish, I think.

I suppose I could mail you my binary though. (But if your build went ok they should be identical, given that we are on the same distro, same GCC/Glib etc.)


#10

Wow, excuse me, it’s the binay version and not the built one that i have :oops:
Don’t know what i had smoked when i’ve read your message :confused:

(please tell me if you see some english parse errors in my posts :D)


#11

Well, it seems to be harder than that, I downloaded the sources of Premake (SVN version, as explained in the Premake version of SourceForge), and i found just one makefile, in a sub/sub/sub/sub/sub/sub directiry of the achive, and it doesn’t work at all :stuck_out_tongue:

Where did you find your Premake sources ?


#12

LOL

go here:
http://sourceforge.net/project/showfiles.php?group_id=71616

Download the file called premake-src-3.3.1.zip


#13

Thanks, how did I do not to see it :roll: i probably thought “SRC” was an OS :shock:

Now Premake works !

So, let’s come back to Juce :
in the directory juce/build/linux, i typed “premake --os linux --file juce_premake.lua” ; eveyuthing seemed fine. Then I typed make CONFIG=Release, and here comes another errors huricane :

:?


#14

Well presumably you’ve not got ALSA installed, because it can’t find the ALSA header file.

If you don’t want to build audio support, you can just turn off JUCE_ALSA in the juce_Config.h file.


#15

is there a way to get a complete list of Juce’s dependencies ?


#16

Try this… (no openGL so either add those *-dev packs or make sure it is not defined in the juce über header)

I’m not sure all of those are actually needed, but what the hell…

Also, if you like to keep track of stuff, like I do… save the output from apt so you can roll back the installation including dependencies. Deborphan is a helpful thing too.


#17

Nice !
It works.
the pb was that libasound2-dev was missing. Many thanks :slight_smile:

Now Juce is built, shall I put some things in /usr/include or /usr/lib to make it usable ?


#18

Include is for header files, lib is for libraries. But you don’t need to put juce there unless you really want to. Just keep it where ever is convenient for you an update the path in the premake file.

Since you typically link juce statically, it doesn’t really matter where it is as long as the linker finds it. (Actually the same is pretty much true for dynamically linked libraries)

Most people keep the Juce folder next to their own project folder I think. It simplifies things since you’ll need to rebuild it every so often.


#19