Making juce in Ubuntu Lucid


#1

I’ve downloaded the juce source and I keep getting all kinds of “missing” library and files problems.
I’ve downloaded an run premake
The last error was:

==== Building JUCE ====
juce_linux_NativeCode.cpp
In file included from …/…/src/native/juce_linux_NativeCode.cpp:37:
…/…/src/native/linux/juce_linux_NativeIncludes.h:122:29: warning: alsa/asoundlib.h: No such file or directory
In file included from …/…/src/native/juce_linux_NativeCode.cpp:114:
…/…/src/native/linux/juce_linux_Audio.cpp:35: error: variable or field ‘getDeviceSampleRates’ declared void
…/…/src/native/linux/juce_linux_Audio.cpp:35: error: ‘snd_pcm_t’ was not declared in this scope
…/…/src/native/linux/juce_linux_Audio.cpp:35: error: ‘handle’ was not declared in this scope
…/…/src/native/linux/juce_linux_Audio.cpp:35: error: expected primary-expression before ‘&’ token
…/…/src/native/linux/juce_linux_Audio.cpp:35: error: ‘rates’ was not declared in this scope
…/…/src/native/juce_linux_NativeCode.cpp:122: error: expected ‘}’ at end of input
make[1]: *** […/…/bin/intermediate_linux/Debug/juce_linux_NativeCode.o] Error 1


#2

Your error message is pointing you at juce_linux_NativeIncludes.h line 122. That line looks like this:

[code] /* Got an include error here? If so, you’ve either not got ALSA installed, or you’ve
not got your paths set up correctly to find its header files.

The package you need to install to get ASLA support is "libasound2-dev".

If you don't have the ALSA library and don't want to build Juce with audio support,
just disable the JUCE_ALSA flag in juce_Config.h

*/
#include <alsa/asoundlib.h>[/code]

I usually disable features like ALSA in release versions to make sure it builds on a lowest-common-denominator machine, but maybe you’re using the latest GIT version or something.