Juce 4.1 error: VST Folder


#1

Hi,

I downloaded the Juce 4.1 but it can't find the VST folder.

What I'm doing wrong?

I attached a PDF file showing this error.

Thanks,
Nyck


#2

You'd have to give it the path to wherever that folder is on your machine.


#3

Yes Jules..I know that...

Please, look the PDF file attached...

I put the path of the VST folder inside Juce 4.1, but I got the error showed in this PDF file.
What I'm doing wrong?

Thanks,
Nyck


#4

I had the same error using the VST3 SDK path for VST2 in VS2015… I just used my VST2.4 SDK path for VST2 and it fixed the problem.

Rail


#5

Thank you Rail Jon Rogut,

I would like to try it, but I'm not finding the VST 2.4 SDK to download....I saw just the 3.6.5 version.
Could you send me this link to download?

Another question:
I would like to know if is possible to use VST 3 SDK inside Juce 4.1. Is possible Jules?

Thanks again,
Nyck


#6

Yes, you should use the VST3 version. It comes with the old VST2 stuff inside it.

I don't understand what you're having problems with... If you set the path correctly, it'll work just fine.


#7


Hi Jules,

Sorry for this question again...but I have to write a VST Audio Plugin for my Master project in the University.

I saw in internet that Juce is the best way to do it.

Did you saw the PDF file attached in this question?

In this PDF file I show the path that I wrote in Juce 4.1 and a Terminal window that shows the VST3_SDK folder path inside my Mac.
I put here:
/Applications/VST3_SDK/

I understand that you don't know what is wrong...but could you check "on more time"?
Or could I put the same question in another places inside this Community?

​It is very important to me!

Thank you very much!
Nyck
 


#8

Have you tried to put the vst files where your compiler actually expects to find them acc to the error message? I.e so audioeffectx.h is found in public.sdk/source/vst2.x/ 


#9

Hi Oxxyyd,

I think tahat the path is correct.
I'm showing the path in this new PDF file attached here. Look this please and tell me what I'm doing wrong.

Thanks,
Nyck