JUCE 5.4.7 on Xcode 12

When I try to build JUCE 5.4.7 with Xcode 12.N I get a lot of these kind of errors:

error: reference to 'Point' is ambiguous

I know these have been address in later versions of JUCE, is it a bridge to far to expect 5.4.7 to build with current versions of Xcode?

Although we try to ensure that the current version of JUCE always builds with the latest compilers, we do not update old versions of JUCE to build with later compilers. If you need to build with Xcode 11 or later, I’d recommend updating to JUCE 6. If you need to stick with JUCE 5.4.7, you will probably need to build with Xcode 10 or earlier.

Thanks @reuk, this is what I thought. And totally understandable.