JUCE 6: unhandled exception deleting VST3 only (Mac)

I have moved my projects to JUCE 6 (from 5.4.7) in the last few days. Now, with my VST3 version, I get an unhandled exception when deleting the filter in AudioPluginHost. But not for the VST or AU versions.

In JUCE 5.4.7 AudioPluginHost, all is well.

Where it crashes is in void MessageManager::runDispatchLoop().

I recompiled the AudioPluginHost with JUCE_CATCH_UNHANDLED_EXCEPTIONS 1, but it is not logging any debug information to the Xcode logger, it doesn’t seem to get to the @catch part (unless I don’t understand what is supposed to happen here).

I have no idea how to proceed here with figuring out what the problem is. Any suggestions appreciated!

You can put an exception breakpoint in Xcodes breakpoint window!

image

I had to do it the other day.

Thanks, I tried that, it doesn’t seem to do anything. I added exception breakpoints for both throw and catch, and it simply crashes at the same point as indicated above with nothing different - unless I’m doing something wrong.

Oh just looked more closely at your picture.

Have you tried running with Address Sanitizer on?

I tried turning on the Address Sanitizer. I’ve never used it before and don’t know exactly what to expect.

When I turn it on (in my plugin project) and then debug while attached to the AudioPluginHost, it crashes (or hits) on creating the plugin, as shown. I don’t know what this reveals or what I’m supposed to do after that point…

I’m also not sure what to do about “interceptors not installed”…

Screen Shot 2020-07-16 at 10.38.34 AM

The details should be in the debug console window. Usually a long stack trace showing the details of the memory error. Though maybe you need to set AudioPluginHost as the ‘Run’ app in the debug settings to get address sanitizer to work? Are you attaching to it after launching?

Thanks for trying to help. Yes, I have set the AudioPluginHost as the Run app, and attached to it with my plugin. I have turned on the AddressSanitizer in both of them, and recompiled both of them with it on.

Today, when I am running it I am not getting the “interceptors not installed” error. I am getting exactly what you see here. Is this not the console window and the stack trace?