Juce compile error Linux


#1

Hi,

I just tried the latest tip 739 and juce does not compile with the following error:

platform_specific_code/juce_linux_AudioCDReader.cpp:66: error: no ‘bool juce::AudioCDReader::read(int**, juce::int64, int)’ member function declared in class ‘juce::AudioCDReader’

Thanks
Kyriacos


#2

Oh, sorry - it should look like this:

[code]bool AudioCDReader::readSamples (int** destSamples, int numDestChannels, int startOffsetInDestBuffer,
int64 startSampleInFile, int numSamples)
{
return false;
}

[/code]

I’ll check a fix in very soon…


#3

Thanks Jules!

Juce library compiled ok.

Now for compiling the audio plugin in juce_amalgamated.cpp lines 259981
should changed also for the same function (AudioCDReader::readSamples).

Also premake.lua for audio plugin is missing the freetype2 include plus I think the paths for vstsdk must be for older version so I included my own path.

my premake.lua file

package.includepaths = {
"/usr/include",
"…/…/…/…/…/",
"…/…/…/…/…/…/…/vstsdk2.4",
"/usr/include/freetype2",
"…/…/src"
}

So plugin compiled ok to libjuceplugindemo.so file.
I tried this in jost 0.5.4 but it is not loading.

Also I compiled the jucepluginhost successfully but the application is not opening (no errors, nothing happens when you run it.)

the jucedemo app compiles and runs ok.

I am using ubuntu 810 and vst 2.4

Thanks
Kyriacos


#4

Thanks for that, I’ll update the premake.lua.

Don’t think I’ve ever actually tried running the plugin host on linux, so you’re on your own debugging that one! If you can step into it, shouldn’t be hard to see where it gets to before it stops…


#5

Hi Jules,

What about the actual plugin? I have tried to compile with both vstsdk 2.3 and 2.4, it compiles ok to libjuceplugindemo.so but it does not load in both Jost and energy XT.

Thanks
Kyriacos


#6

In need to apply the following change in src/host/MainHostWindow.cpp in order to prevent a crash of the audio plugin host on linux

-    deviceManager.initialise (256, 256, savedAudioState, true);
+    deviceManager.initialise (2, 2, savedAudioState, true);

I believe this is due to hardcoded max nb of channels such as
"static const int maxNumChans = 64;" in juce_linux_Audio.cpp but I did not really try to understand the details to be honest…


#7

Hi jpo. I have tried your mod and now plugin host is opening ok.
I have noticed in the linux version when you select “edit the list of available plugins” in the “options” button menu the item “scan for new vst plugins” is missing so you can not change the directory for scanning your plugins. I will check some more and post the results.

Thanks
Kyriacos