Juce Demo in iPhone/iPad simulator


#1

I’ve downloaded the latest XCode 3.2.5 and installed the iOS4.2 SDK. When I start the Juce Demo app, the iPad simulator comes up, but the Juce Demo app icon is just a metallic icon. I click on it, and a small empty window (probably representing an iPhone?) appears and immediately quits again. If I select any other Active Executable then iPad Simulator 3.2, the selection jumps back to iPad Simulator 3.2.
This is with the tip on 10.6.5. I’ve never tried iPhone/iPad stuff before so there might be something I’m missing?


#2

Sounds like it’s to do with the Base SDK. Go into the Juce Demo target settings and change the Base SDK to iOS 4.2. Then close the project and reopen it and it should work. If you don’t close and reopen the project, Xcode doesn’t seem to pick up the new SDK setting properly.

Although the icon does seem to be the plain one…


#3

Doesn’t seem to make a difference. Changed to iOS 4.2 as Base SDK (it was set to iPhone 3.2), build again (after restarting XCode, pressing Clean and rebuilding). I also tried to set the setting to 4.2 in the simulator. No change.


#4

ok, works now.


#5

what was it?


#6

I’ve also had some problems here.

The Juce iOS example project was configured to use the base Mac SDK (!) for some reason.
I changed this to use the latest iOS SDK, changed the architecture to arm 6/arm 7 instead of default arm6.
I also set the target to iOS 3.2 and later (so I can target older iPads/iPhones).

Now after a rebuild & launch with Simulator, fails to run almost immediately, complaining about a call to a system function that should be fine.

I double-checked with XCode, and the Target SDK settings under XCode claim Dev target, even though I’m trying to target the Simulator; explains why it fails at start-up at least - my non-Juce iOS projects show something different for this setting.

Amazing how painful XCode can be when things don’t go quite according to plan. :slight_smile:

I guess I’ll have to reboot etc. and try again!

Pete


#7

I’ve now got this working - see http://www.rawmaterialsoftware.com/viewtopic.php?f=4&t=6484 for my notes on what to do - quite easy! :slight_smile: