Juce Demo on iPhone


#1

I tried to build the Juce Demo for iPad simulator debug from the iPhone build directory and this is the message I get after a crash on launch:

JUCE v1.53.7
Detected an attempt to call a symbol in system libraries that is not present on the iPhone:
getrlimit$UNIX2003 called from function _ZN4juce11SystemStats15initialiseStatsEv in image JuceDemo.
If you are encountering this problem running a simulator binary within gdb, make sure you ‘set start-with-shell off’ first.

Any ideas?


#2

I haven’t tried it myself in Apple’s latest SDK yet - could be that they’ve changed something. I’ll have a go as soon as I can…


#3

any news?
I’ve the same problem on iPad…


#4

I’ve been running it on the ipad simulator with no problem. Can’t really think what you’d be doing that’d break it.


#5

I’ve no problem runnin the demo on the iPhone, but on Ipad the running stops on the SystemStats::initialiseStats() inside initialiseJuce_NonGUI()…


#6

Like I said, I was running it for iPad too. Maybe there’s a difference in the OS version we’re using. TBH the getrlimit call isn’t really essential on iOS, I could probably just remove it for that platform.


#7

No problems here on Xcode 3.2.6 + iOS 4.3. Juce Demo working fine on the iPad simulator and device (iPad2). The only issue I have is having to turn off thumb code in the debug build for the device otheriwse two of the amalgamted files fail to compile (see antoher thread in the Mac & iOS forum).

(The only minor issue is the audio recording tab doesn’t seem to record the file into the documents directory on the device.)


#8

I’m running XCode 3.2.6 and IOS 4.3 too, but I can compile only targeting iPhone 4.0 and iPhone 4.1.
If I try targeting iPad 3.2 or superior and iPhone 4.2 or superior it stops here

int juce_iOSMain (int argc, const char* argv[])
{
return UIApplicationMain (argc, const_cast<char**> (argv), nil, @“JuceAppStartupDelegate”);
}

The debugger says ‘GDB : Program received signal : SIGABRT’ and the iPad simulator stops on a black screen…


#9

I’m also targeting 4.2 with no problem. If you’re not even getting past the main() call, then something sounds extremely broken with your build!


#10

I’m tryng to build the Juce Demo and Juce example projects from a fresh Juce download but I’ve the same problem…
I’m thinking…maybe there’s some strange behaviour on the path in argv string and it can’t return the exact application path???


#11

Fresh from GIT or the latest release? Monad cited “JUCE v1.53.7” back in Janurary with the problem but the lates build no is 79 now (i.e., 1.53.79).


#12

Downloaded 1.53.79 and it works really fine now!!! I’ve struggled 2 days with XCode and I didn’t thought about download the latest build of Juce, but I’m too tired 'cause I’m working on my degree project

I was using Juce 1.52 :smiley:

Thanks a lot guys…