Just a little bug in Projucer


#1

I’ve only tested this on OSX - But here’s a video

Selection bug

It’s on OSX 10.11.4. Projucer was just downloaded today, it’s 4.2.0, build date of April 6, 2016.

Note that in the video I’m only clicking on the items one time and it deselects them after a very brief period of time.

I looked around for a bug reporting place and didn’t find one, sorry if this is the wrong spot.

Edit: It’s actually really annoyingly everywhere within the application. For example, if I go to Tools > Global Preferences, it’s constantly bring the focus back to the main application. I can’t get something selected and changed within the 1/10th of a second I have before focus is drawn away from the active window.


#2

That’s odd, I also have 10.11.4 and I don’t see this problem at all! Neither with the Projucer from the website, nor if I compile it myself. Can’t reproduce it!

Does it happen always or only sometimes? What if you restart? Maybe another app that you run simultaneously messes around with the focus or something? Can you reproduce this on another Mac?


#3

Sorry, don’t have another Mac. It’s always happening, no matter if I restart the computer or restart the application. And here’s what happens when I have multiple instances open beside each other. I’m not touching the keyboard or anything in this picture, I just click the first instance in the first few seconds and then the focus keeps switching between instances.


#4

This is super odd, and I don’t see any of that on my Mac!

Maybe a key is stuck or something like that? Did you notice any odd behaviour in any other app?


#5

No, same result when I have my Das keyboard plugged in and when I use the standard Mac keyboard when the Das isn’t plugged in. No other behavior like this between apps. No instruments plugged in either, so no rogue signals coming in.


#6

I had something like this with a laptop my son had connected to a keyboard and external monitor. Turned out the laptop wasn’t fully closed and the monitor cable got sandwiched between the screen and the keyboard, depressing one of the keys.

With the laptop sitting behind the monitor I didn’t notice until after I’d spent quite a while checking for faulty drivers and malware. That’s a couple of hours of my life I won’t get back :confounded:


#8

FYI I think I’ve just fixed this bug, but can’t be 100% sure it’s the same thing you guys are seeing, so let me know if there are still any problems!


#9

Download link isn’t working, @jules

https://www.juce.com/download


#10

You can use juce.com/downloads
Not sure why the other one doesn’t work, but we’ll have a look at that, thanks.


#11

Hi @jules,

Thanks for having a go at it, but unfortunately, this bug still persists.
Selecting any of the modules in the navigator, immediately gets undone: selection returns to the top level node in the navigator (which is the project name).

Also: when collapsing a node, it immediately gets expanded again.

Same behaviour in each module’s page, e.g. for jude_audio_devices, when clicking the JUCE_ASIO menu, it immediately gets reset.

The only UI elements, not susceptible to this issue are the Files, Config and Build tab buttons.


#12

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#13

Definitely fixed this. At least, I fixed the problem I found, which may be a different one, but I couldn’t reproduce it - if you can tell us exactly how to make it happen in the latest code, let me know.

But I suspect the real problem is that you’re not actually running the latest projucer - check its version number!


#14

This bug persists in Projucer 4.2.1.
There isn’t anything special you need to do to trigger it, just download, unzip and run the Projucer.app :slight_smile:

Tested on Mac OS X 10.10 Yosemite and 10.11 El Capitan.

Please address! :cold_sweat:


#15

@jules: I have found an exact reproduction scenario, and a workaround.

First of all, my account “does not have an associated JUCE Pro” license.
When I log in in the Projucer, I have the above described bugs, where practically all of the buttons lose focus.
When I log out, all of a sudden the bug is gone.
So maybe when logged in, there are license checks which mess with the button focus or anything like that.

Anyway: Logging out is a workaround for now, but obviously this should still be addressed :slight_smile:


#16

Ah, thanks! There’s some messy logic in there and this was a case that we hadn’t tried… Should be OK now!