Linker Error after git update


#1

Hi,

just updated to latest git and got the following linker errors but only on MAC when I compile my project:

Ld /Users/FinalFanta54321/Library/Developer/Xcode/DerivedData/VCommander-cahmngejdamnhqfrpsrqzjogfypw/Build/Products/Debug_Standalone/VCommander_debug.app/Contents/MacOS/VCommander_debug normal i386
cd “/Eigene_Dateien/VST_Development/Eigene Projekte/VCommander/Standalone/Builds/MacOSX”
/Developer/usr/bin/llvm-g+±4.2 -arch i386 -L/Users/FinalFanta54321/Library/Developer/Xcode/DerivedData/VCommander-cahmngejdamnhqfrpsrqzjogfypw/Build/Products/Debug_Standalone -F/Users/FinalFanta54321/Library/Developer/Xcode/DerivedData/VCommander-cahmngejdamnhqfrpsrqzjogfypw/Build/Products/Debug_Standalone -filelist /Users/FinalFanta54321/Library/Developer/Xcode/DerivedData/VCommander-cahmngejdamnhqfrpsrqzjogfypw/Build/Intermediates/VCommander.build/Debug_Standalone/VCommander.build/Objects-normal/i386/VCommander_debug.LinkFileList -framework Cocoa -framework Carbon -framework IOKit -framework CoreAudio -framework CoreMIDI -framework WebKit -framework DiscRecording -framework OpenGL -framework QuartzCore -framework QTKit -framework QuickTime -o /Users/FinalFanta54321/Library/Developer/Xcode/DerivedData/VCommander-cahmngejdamnhqfrpsrqzjogfypw/Build/Products/Debug_Standalone/VCommander_debug.app/Contents/MacOS/VCommander_debug

Undefined symbols for architecture i386:
"_AudioFileOpenWithCallbacks", referenced from:
juce::CoreAudioReader::CoreAudioReader(juce::InputStream*)in JuceLibraryCode4.o
"_ExtAudioFileWrapAudioFileID", referenced from:
juce::CoreAudioReader::CoreAudioReader(juce::InputStream*)in JuceLibraryCode4.o
"_ExtAudioFileGetProperty", referenced from:
juce::CoreAudioReader::CoreAudioReader(juce::InputStream*)in JuceLibraryCode4.o
"_ExtAudioFileSetProperty", referenced from:
juce::CoreAudioReader::CoreAudioReader(juce::InputStream*)in JuceLibraryCode4.o
"_ExtAudioFileDispose", referenced from:
juce::CoreAudioReader::~CoreAudioReader()in JuceLibraryCode4.o
juce::CoreAudioReader::~CoreAudioReader()in JuceLibraryCode4.o
"_AudioFileClose", referenced from:
juce::CoreAudioReader::~CoreAudioReader()in JuceLibraryCode4.o
juce::CoreAudioReader::~CoreAudioReader()in JuceLibraryCode4.o
"_ExtAudioFileSeek", referenced from:
juce::CoreAudioReader::readSamples(int**, int, int, long long, int)in JuceLibraryCode4.o
"_ExtAudioFileRead", referenced from:
juce::CoreAudioReader::readSamples(int**, int, int, long long, int)in JuceLibraryCode4.o
"_AudioFileGetGlobalInfo", referenced from:
juce::(anonymous namespace)::findFileExtensionsForCoreAudioCodecs()in JuceLibraryCode4.o
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status

I am not an MAC expert so any help is appreciated!
Any idea where I should look at?

Thank you!
Joerg


#2

there was some info about it you need to add a new Framework called “AudioKit” or “CoreAudioKit” the new Introjucer adds it to your projects so if you are using it, re-build introjucer and open/save your projects.


#3

Thank you atom!

Joerg