Mac compatibility issues

I’m going crazy trying to figure out why my plugin is not appearing on some older mac systems. I have the following settings set in the jucer:

image

I’ve tried building on my personal m1 arm macbook as well as an older 2016 intel macbook and it still won’t appear on a couple users macs. I am not sure if it’s an OS issue because for one user they upgraded from 10.11 to Catalina and the plugin will still not show up. We even tried running “auval -a” and it’s not appearing in their list of plugins. I’ve tried building for 32bit/64 bit architecture but I guess this option is deprecated.

I’m a bit at a loss how to proceed, I’ve read various threads on this subject but it all seems like voodoo to me to actually figure out what the root cause is.

Any advice??

use 10.12 SDK that you copy manually into xcode

and notarize on a <= 10.15 OSX machine

Oh thank you! I’ll check this,

“use 10.12 SDK that you copy manually into xcode” ← where do I copy this?

Appreciate the info

You’re a lifesaver, I’ll try this out and see how it goes. Cheers!