MacOs Ventura 13.0 problems

Hello,
Just updated to Ventura 13.0. In Logic Pro X the plugin now is just the blank (black) screen instead UI. Juce Version 6.1.6.

Do someone have any ideas what it can be?

Thank you

1 Like

Do you use OpenGL?

No

Do you call a copy protection function or other popup window before the GUI has been initialized? This was a problem I ran into with Ventura and Logic Pro X - the popup windows for the copy protection were being called before the GUI was drawn.

Otherwise, you might want to check AUHostingService (or whatever it is called) in Activity Monitor to see if it has crashed. Easy way to tell this: try opening up one of Apple’s own AUs after you have tried to open your own plugin.

Good luck!

Sean Costello

1 Like

Thank you. Will try.

  1. No
  2. Apple’s own plugins work

I found a place what is stopped working

SystemStats::getOperatingSystemType() return “UnknownOS”. Couldn’t find it earlier, because Xcode was updating.

2 Likes

SystemStats broke for our apps on Ventura update as well — we switched over to using the if / defs although I like them less

Have you tested this on the develop branch?

1 Like

Yes it works now but it broke existing shipped products — it would be nice if it didn’t considering everything else inside JUCE translated to the new OS no problem

1 Like

+1

can SystemStats::getOperatingSystemType() be fixed such that in future this will hold true regardless?

To test whether any version of OSX is running, you can use the expression ((getOperatingSystemType() & MacOSX) != 0).

If that can be fixed to always be true for “unknown” versions of macOS it would solve issues a lot of people seem to have had going forward.

5 Likes
5 Likes

Is there a problem with openGL on Ventura?

Not specifically that I’m aware of, but I’ve seen “black plugin windows” as a result of OpenGL issues in the past, so was speculating about reasons.