Modules not loading VS17


#1

Hi all, I hope this is the right place to ask this, was reccomended to ask here after the /learnprogramming subreddit. Essentially I’m trying to do my first “Hello World” project using Juce, but when I open the project in my IDE (VS17) I’m getting “Cannot open source file “x.h”” for 625 different headers. These headers work outside of a Projucer created project (I mean one of them is stdio.h) and I just don’t have the knowledge to be able to figure out why it isn’t working. I set the user modules path in Projucer to my System32 folder (if thats wrong I’m sorry and also am dumb).
Any suggestions would be hugely appreciated and let me know if you need more info!
Thanks in advance xxxxx


#2

That’s wrong, you should only set that path if you have custom made JUCE modules of your own.

Did you set the path for modules provided by JUCE correctly?


#3

Ah okay my apologies, as you can tell I’m really really unsure of that side of C++ and where all the modules etc are located. I did, heres what I’m seeing in the projucer module path bit

I haven’t touched the SDK section, and I suspect it’s the User Modules bit giving me grief, but I’m not sure where to point it


#4

You are not supposed to point the User Modules path anywhere if you don’t have custom JUCE modules. (That is, leave it empty, making it point to something like system32 is likely just going to confuse things further.) The paths otherwise are looking OK, so the issue could be somewhere else. A common thing that happens is that Visual Studio was not installed with the necessary SDKs for JUCE based development.


#5

Oh sorry, I’m with you now! That would make sense as when I installed VS I tried to leave it as barebones as I could because my SSD with Windows on it is running out of space pretty quick, do you know off the top of your head what SDKs I need to get? Sorry again I feel so dumb ahhaha, thanks so much for your time!


#6

These are the options I have :

There may be some things enabled that are not actually needed.


#7

Just downloading the correct Windows 10 SDK worked, thank you so much for pointing me in that direction I really appreciate it, have a great evening!